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About This Manual 

Release Notes 

The manual applies to GENEX Air Interface Testing Software V100R003. 

Organization 

The manual consists of 12 chapters and two appendixes. 

Chapter 1 Introduction to GENEX Probe, Chapter 2 Quick Start, and Chapter 3 
New Functions mainly introduce the basic functions, quick start, and new functions 
of the system. 

Chapter 4 Installing the Probe mainly introduces the hardware requirements and 
the installation method. 

Chapter 5 User Interface gives a fully description of system interface and parameter 
windows. Users can get familiar with the system interface after reading this chapter. 

Chapter 6 Managing the Project describes the test project management of Probe 
system. Users can get acquainted with the concept of test project and some basic 
operations. 

Chapter 7 Connecting the Devices introduces the connection and configuration of 
test devices, such as UE, GPS, Scanner. This part is the essential for the test 
preparation, and should be attached with enough attention. 

Chapter 8 Configuring Test Plan gives a panoramic view on how to configure a test 
plan. 

Chapter 9 Controlling the Test and Playing the Log File Back introduces the test 
control and log play during and after the test.  

Chapter 10 Continuous Wave Test emphasizes on the CW test. 

Chapter 11 File Exporting Function describes how to export the data. 

Chapter 12 FAQ uses the FAQ format to give solutions to problems commonly 
encountered during the operation. 

Appendix A Common Parameters   describes the common parameters in Probe 
and some equipment. 
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Appendix B Acronyms and Abbreviations describes the full name of the 
abbreviations in the manual. 

Intended Audience 

The manual is intended for the following readers: 

 Marketing staff 
 Installation engineers & technicians 
 Operation & maintenance personnel 

Conventions 

This document uses the following conventions:  

I. General conventions 

Convention Description 

Arial Normal paragraphs are in Arial. 

Arial Narrow Warnings, Cautions, Notes and Tips are in Arial Narrow. 

Bold Headings, Command, Command Description are in 
boldface.  

Terminal Display Terminal Display is in Courier New; message input by the 
user via the terminal is in boldface. 

 

II. Symbols  

Eye-catching symbols are also used in the manual to highlight the points worthy of 
special attention during the operation. They are defined as follows: 

  Caution, Warning, Danger: Means reader be extremely careful during the 

operation. 

  Note, Comment, Tip, Knowhow, Thought: Means a complementary 
description. 
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Chapter 1  Introduction to the GENEX Probe 

1.1  Overview 

As an excellent tool for air interface tests in the WCDMA, HSDPA, GSM or GPRS 
systems, the GENEX Probe is used to verify the results of radio network planning and 
optimization, and give guidance to troubleshooting. The Probe supports the Scanner 
and test UEs. Table 1-1 lists the features of the Probe. 

Table 1-1 Features of the Probe 

Feature Description 

Conducting continuous wave 
(CW) test 

The Probe averages and exports the measured 
data. 

Measuring signal strength 
and quality 

The Probe measures the signal strength and 
quality, and combines the measurement data with 
the geographic data. 

Parsing messages on the air 
interface 

The Probe parses the messages on the layer 2 and 
layer 3 in the WCDMA system and those on the 
layer 3 in the GSM system.  

The Probe collects the wireless parameters on 
layer 1. 

Initiating CS and PS services 
automatically 

The manual configuration of functions and QoS 
parameters makes the testing easier. Real-time 
voice prompts and other icon prompts make the 
testing more user-friendly. 

Locating network faults more 
easily 

The stable and reliable data records, automatic 
reconnection with the devices, controllable log 
playback, and the co-activated information display 
make the network problem searching much easier.

Providing automatic and 
extendable event list 

The automatic and extendable event list can 
assistant you in analyzing calling performance. 

Test data saving, exporting, 
combing, playbacking 

These functions realize the playback of the test 
process and offer original test data for other 
post-processing tools. 
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1.2  Main Functions 

Table 1-2 lists the main functions of the Probe.  

Table 1-2 Main functions 

Function Description 

Dual-mode test in 
WCDMA/HSDPA/GSM/GPRS

The Probe collects wireless measurement 
parameters and signaling. By using different UEs, 
the Probe measures the parameters and 
messages of the system. In addition, the Probe 
supports the coversion among different modes.  

CS and PS measurement 

The Probe conducts various service tests, 
including the CS and PS tests.  

For the CS service, the Probe tests:  

 Continuous call 

 Call by call  

 Video phone measurement 

For the PS service, the Probe tests:  

 PING 

 FTP 

 HTTP 

 Video Streaming 

The Probe also conducts the simultaneous test of 
SMS, CS services, and PS services.  

The Probe reports the progress of the process in 
real time and gives the statistic report after the 
test.  

For the Scanner, the Probe conducts:  

 CW measurement 

 Pilot Scan 

 Spectrum Analysis  

Multi-UE test 
The Probe can conduct simultaneous test on the 
UEs (eight at most), the Scanner, and the GPS. 
Each UE executes different measurement tasks. 
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Function Description 

Scanner measurement 

The Probe supports: 

 Anritsu Scanner 

 DTI Scanner  

Indoor measurement 

In addition to the outdoor measurement, the 
Probe also supports walking measurement and 
vertical measurement.  

 Walking measurement: Refers to an indoor 
plane test. It measures and displays the inside 
signal distribution of a building.  

 Vertical measurement: Measures the 
vertically-distributed signals in the elevators. 

Preset of test plan 

The Probe can preset, import, and export the test 
plan. Moreover, the Probe is capable of displaying 
the execution result. The preset of test plan 
means that the Probe sets down the test plan for 
test device. Take the UE for an example. Set such 
test plans as calling test, FTP sending or loading, 
or concurrent service tests.  

After the test begins, the Probe automatically 
executes the test plan items one by one. 
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Function Description 

Judgment of predefined 
events 

The Probe gives the judgment and the statistics of 
the key events as follows:  

 Call setup event 

 Channel connection event 

 Channel release event 

 Call drop 

 Handover 

 PDP context activation 

The Probe offers two display modes for the 
events mentioned previously:  

 On the map window 

 In the event list 

Note:  

The display of the events with special icons on the 
map window enables you to have a panoramic 
view of the network performance, while the event 
list facilitates the calculation of the times and 
frequency of event occurrence.  

Hardware alarm 

The Probe supports alarms under special 
situations.  

For instance, when a device is unexpectedly 
disconnected or the GPS signal is inadequate, the 
Probe warns you of the alarms in the form of 
either dialog box or sound. You can perceive the 
change of the connection status in real time.  

Measure parameter filtering 

The log mask filtering supports selective reception 
of parameters. 

In case of GSM service test, select it to report the 
associated parameters. 
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Function Description 

Sampling rate setting 

In the Probe, you can set the sampling rate for 
certain parameters.  

Note: 

In the Probe, some of the parameters are read at 
a high frequency level, which results in heavy 
data volume and system resource consumption. 
Therefore, Huawei recommends setting the 
sampling rate for some special parameters, such 
as List Search and Finger Info for TA. 

Log recording,  playbacking, 
combining, exporting function

The Probe saves the test data into the LOG file in 
the manner of real-time refresh to enhance the 
security.  

The LOG data can be exported to a .bin, .text, 
or .xls file. The exported log file can be analyzed 
by the post-processing tools such as the GENEX 
Assistant, the ACTIX Analyzer, and the U-Net.  

The LOG data that conforms to certain constrains 
can be combined together. 

Co-activated information 
display  

The co-activated information is displayed if you 
click a record in a window like a signaling, map, or 
event window. The display of co-activated 
information helps you to locate and analyze the 
network troubles.  

Geographic display of 
wireless measurement 
parameter 

The Probe displays the following on the map:  

 Measurement track  

 Parameter value 

 Legend 

 Switchable data 

 Base station  

 Pilot line 

The Probe supports the import of raster maps. 
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Function Description 

Dynamic and static 
adjustment to GPS 
information 

The inaccurate GPS information caused by map 
error or dense building has great influence on the 
correctness of geographic display.  

Therefore, the Probe corrects the test track by the 
dynamic adjustment (shifting and angle 
adjustment) or the static adjustment (dragging or 
rotating).  

Display of air interface 
messages 

The Probe is capable of parsing the following 
messages: 

 MAC/RLC signal 

 NAS signal 

 RRC signal 

 GSM RR signal 

Display of RLC and APP 
throughput 

Display of uplink and downlink thoughputs of the 
RLC and APP.  

Display of custom parameters
You can add, delete, or configure the parameters 
as required.  

GPS time synchronization 

The Probe synchronizes with GPS standard time. 
If a high level of time precision is required, apply 
the GPS standard time to the operating system.  

When searching for GPS or DTI Scanner, the 
system sets the local time as GPS standard time 
automatically so long as the system is connected 
to the GPS and sets to synchronize with the GPS 
standard time. 

QoS 
The Probe gives the information statistics on the 
service layer. 

Comparison test 
The Probe conducts comparison tests for different 
UEs in the different networks. 

 

1.3  How to Use This Manual 

This section contains the following parts: 

 About the Manual 
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 Intended Reader 

1.3.1  About the Manual 

This manual details the basic functions, the installation and running environments, the 
system interfaces, and the basic operations in the GENEX Probe. The chapters in this 
manual follow the natural process flow, and emphasize on the essential functions.  

The main contents of the chapters are as follows: 

 Chapter 1  "Introduction to the GENEX Probe", Chapter 2  "Quick Start", and 
Chapter 3  "New Functions" mainly describes the basic functions, quick start, 
and new functions of the system. 

 Chapter 4  "Installing the Probe" details the hardware requirements and the 
installation methods. 

 Chapter 5  "Graphical User Interface" gives a fully description of system 
interfaces and parameter windows. You can get familiar with the system 
interfaces after reading this chapter. 

 Chapter 6  "Managing the Project" describes the test project management in the 
Probe. You can get acquainted with the concept of test project and some basic 
operations. 

 Chapter 7  "Connecting the Devices" profiles the connection and configuration of 
test devices, such as UE, GPS, and Scanner. This part is the essential for the test 
preparation, and should be attached with enough attention. 

 Chapter 8  "Configuring Test Plan" gives a panoramic view on how to configure 
a test plan. 

 Chapter 9  "Controlling the Test and Playing the Log File Back" describes the 
test control and log play during and after the test. 

 Chapter 10  "Continuous Wave Test" emphasizes on the CW test. 
 Chapter 11  "File Exporting Funtion" describes how to export the data. 
 Chapter 12  "FAQ" gives solutions to problems commonly encountered during 

the operation. 
 Appendix A “Common Parameters and Shortcuts” describes the common 

parameters and shortcut keys frequenctly used in the Probe. 
 Appendix B “Acronyms and Abbreviations” lists the explanations for the 

abbreviations and acronyms occurred in the manual. 

1.3.2  Intended Reader 

This manual is designed for new users to learn how to use the system step by step, 
and for the users who familize themselves with the system to investigate further about 
their concerned functions. 
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Chapter 2  Quick Start 

2.1  Overview 

This chapter contains the following contents: 

 Installing the Probe 
 Creating or Opening a Project 
 Testing the Terminal Configuration 
 Setting a Test Plan 
 Opening the Parameter Window 
 Saving the Test Project 
 Beginning a Test 
 Ending a Test 

2.2  Installing the Probe 

Before running the Probe, ensure that the Probe is properly installed. For details, refer 
to Chapter 4  "Installing the Probe." 

2.3  Creating or Opening a Project 

To create or open a project, perform the following steps:  

1) Run the Probe. 
2) Choose New Project on the File menu. Alternatively, choose Open Project to 

open an existing project.  

2.4  Testing the Terminal Configuration 

The Probe supports the following test devices:  

 UE 
 Scanner 
 GPS 

Connect and set the test device before test. Take the UE (Qualcomm 6250) for an 
example. For details, refer to Chapter 7  "Connecting the Devices." 

To test the terminal configuration, perform the following steps: 

1) Connect the UE to the USB of the PC through the data line.  
2) Open the UE and keep it active.  
3) Choose SETTINGS > Extras > SIO Configuration > Port Map > Diag on the UE 

main menu. 
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4) Select UART1 (COM1) or UART (COM3) based on the number of the port that 
connects UE with the local PC.  

5) Choose SETTINGS > Extras > SIO Configuration > DS Baud on the UE main 
menu. 

6) Set the baud rate to 115200.  
7) Choose Configuration > Hardware Config > ManualConfig on the Probe main 

menu.  
A dialog box is displayed, as shown in Figure 2-1.  

 
Figure 2-1 ManualConfig dialog box 

8) Click  to add the device.  

The system displays the Device Config dialog box, as shown in Figure 2-2.  
9) Set as shown in Figure 2-2 and click OK.  

10) Click  to search the device.  

The device can be found only when it is correctly connected. 
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Figure 2-2 Device Config dialog box 

 

  Note: 

The Com Port is configured based on the Diag Port mapped by the UE. If the data 
service is tested, the Modem Port needs to be configured, for the Probe conducts the 
dialup and observes the throughput on the application layer. 

 

2.5  Setting a Test Plan 

  Note: 

The custom test plan is used for automatic test. An example is listed below. For details, 
refer to Chapter 8  "Configuring Test Plan." 

 

To set the test plan, perform the following steps:  

1) Choose Configuration > System Config on the main menu.  
The system displays a screen, as shown in Figure 2-3.  
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Figure 2-3 System ConfigProperties 

2) Click Test Item and choose Voice Call. 
3) Set the voice call parameters, such as, call number and calling time, as shown in 

Figure 2-4. 

 

Figure 2-4 Setting parameters 

4) Click OK. 
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2.6  Importing the BS Engineering Parameters 

For the outdoor drive test, the import of the BS engineering parameters facilitates the 
observation of the information about the BS and cell distribution around the test points. 
For details, refer to section 6.5  "Importing the Engineering Parameter." 

2.7  Opening the Parameter Window 

To open the parameter window, double-click each node in the View navigator to query 
the associated data. For details about each window, refer to section 5.4  "View 
Window." 

For the outdoor drive test in which the test tracks need to be checked, you can open 
the Map window and import the map. For details, refer to section 6.6  "Importing a 
Map." 

2.8  Saving the Test Project 

To save the test project, choose File > Save on the main menu. The engineering file is 
saved in .xml format. 

The test plan can be saved either in the engineering file, or individually. For details 
about saving the test plan individually, refer to part 6.7.1  "Setting a Test Plan." 

2.9  Beginning a Test 

Click  in the toolbar to begin the test. You can control the test process and 

observe the data changes in the signaling window. For details, refer to Chapter 9   
"Controlling the Test and Playing the Log File Back." 

2.10  Ending a Test 

Click  in the toolbar to end the test. Playback the Log file created during the drive 

test or export the data. 

For details about the playback of the log file, refer to section 9.6  "Controlling the Log 
File Playback." 

For details about the export of the test data, refer to Chapter 11  "File Exporting 
Funtion."
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Chapter 3  New Functions 

3.1  Overview 

The following functions are added in the GENEX Probe 1.3: 

 Analyzing the HSDPA Parameter Statistics 
 Giving the QoS Statistics  
 Conducting Comparative Tests with Different UEs in Different Networks 
 Predefining the Intra- or Inter-Frequency Handover Events 
 Providing More Test Devices  
 Combing and Exporting the Files 
 Displaying the GSM Parameters in the Chart Window 
 Configuring the DTI Scanner Gain Parameter 
 Conducting the Tests on Commercial UEs 
 Displaying the DTI Scanner Multi-Frequency Data in the Map Window 
 Adding the LogMask Dynamically 
 Opening the Most-Recently-Used Log File 
 Displaying and Scaling the Chart with Multiple Y-Axes 
 Selecting the Device in the Chart or Sheet Window 
 Adding Wait Option in Test UEs 

3.2  Analyzing the HSDPA Parameter Statistics 

The following information about HSDPA parameter is added in the Probe:  

 Collecting the HSDPA data 
 Decoding and giving the statistics of the HSDPA data packet 
 Giving the statistics of throughput on the radio link layer 

3.2.1  Displaying the HSDPA Physical Channel Data 

The data of HSDPA physical channel in the Probe is the configuration parameters of 
the following channels:  

 HS-DSCH 
 HS-SCCH 
 HS-DPCCH 

3.2.2  Providing the HSDPA Decoding Statistics 

The function of HSDPA decoding refers to the decoding statistics on the HS-SCCH 
and HS-DSCH channels. 
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The Probe provides the following statistics: 

 HS-SCCH schedule success rate 
 Block error rate (BLER) on the MAC layer 
 BLER on the RLC layer 

3.2.3  Distinguishing the HSDPA Channels 

The Probe counts how many radio links are available on the downlink, and tells 
whether the service is carried on the DCH or HS-DSCH. 

3.2.4  Providing Statistics on HSDPA Rates 

The HSDPA rates in the HSDPA rate statistics consists of 

 Scheduling rate of the physical layer 
 HSDPA rate on the MAC layer (including the retransmission rate) 

3.2.5  Providing Statistics on HSDPA Channel Quality 

The HSDPA channel quality statistics consists of: 

 BLER on MAC layer 
 BLER on RLC layer 
 Retransmission rate on the HS-DSCH channel 
 CQI 
 Channel utilization 
 Code occupancy 

3.2.6  Displaying HSDPA Parameters in the Map Window 

The Probe displays the HSDPA parameters in the map window.  

3.3  Giving the QoS Statistics 

The Probe provides the QoS statistics on the application layer by offering the KPI 
statistics and throughput of the HTTP and FTP. The QoS statistics is detailed as 
follows: 

 KPI statistics of PING service 
For example, the display of packet loss ratio and time interval between single 
tests. 

 KPI statistics and HTTP throughput 
The KPI statistics and HTTP throughput include the statistics of page access time, 
page download time, and average rate.  

 KPI statistics and FTP throughput 
The KPI statistics and FTP throughput include the statistics of login time, time for 
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forward and download, average rate of forward and download, and the display of 
actual transmission duration. 

 PDP statistics 
The PDP statistics includes the statistics of the minimum, maximum, and average 
rate of the PDP context activation time. 

3.4  Conducting Comparative Tests with Different UEs in 
Different Networks 

The Probe can conduct comparative tests of CS service in different networks.  

The comparison test items consist of 

 Voice call test items 
 Video phone test items 

3.5  Predefining the Intra- or Inter-Frequency Handover 
Events 

The Probe predefines the success and failure events of the intra- or inter-frequency 
handover handovers. These handover events consist of: 

 IntraFreqHHOSuc 
 IntraFreqHHOFail 
 InterFreqHHOSuc 
 InterFreqHHOFail 

3.6  Providing More Test Devices 

The Probe V1.3 supports more test UEs than the ealier version. The new test UEs are: 

 Huawei U526 
 Huawei U636 
 Huawei E600 data card 
 Huawei E620 data card 
 Qualcomm TM6275 
 DTI Scanner 1800M 
 DTI Scanner 1900M 

3.7  Combing and Exporting the Files 

The Probe V1.3 log file post-processing can: 

 Export .log files in the format of QXDM. 
 Export UE measurement data. 
 Export UE signaling list. 
 Export original data of different devices. 
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 Combine .log files. 
 Export the orginal data or separate the DTI Scanner information from the GPS 

information during the log combination. 

3.8  Displaying the GSM Parameters in the Chart Window 

The Probe V1.3 is applicable to the GSM network. The system adds more windows for 
parameter display.  

The windows are used to: 

 Display the signal strength of serving cell under GSM idle state 
 Display the cell selection and parameter re-selection in the GSM network 

3.9  Configuring the DTI Scanner Gain Parameters 

The gaining parameters configurable on the DTI Scanner include the antenna gain 
and cable loss. The configuration result influences the display and the export of DTI 
Scanner data. 

This DTI Scanner gaining parameter enables the complete cancellation of antenna 
gain and cable loss. 

3.10  Conducting the Tests on Commercial UEs 

The Probe opens the tests with commercial UEs by removing the existing bugs in AT 
command edition module.  

The commercial UEs take the place of test UEs to conduct the automatic dialing test. 
By this means, the disadvantages of test UEs at the early stage of network 
construction can be avoided. 

3.11  Displaying the DTI Scanner Multi-Frequency Data in the 
Map Window 

The Probe displays the multi-frequency data of the DTI Scanner in the map window.  

3.12  Adding the LogMask Dynamically 

The Probe adds the LogMask dynamically. For the unlisted LogCode on the layer 1 
and layer 2, if they are required, you can add them manually during LogMask 
configuration.  

3.13  Opening the Most-Recently-Used Log File 

The Probe records the paths and names of the .log files recently used. Five records 
are the maximum. You can open the .log file on the LogFile menu.  
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The system refreshes the records each time when the file is open.  

3.14  Displaying and Scaling the Chart with Multiple Y-Axes 

With this function, you can zoom in or zoom out the multiple Y-axes of the chart.  

3.15  Selecting the Device in the Chart or Sheet Window 

To select the device in the chart or list window, perform the following steps: 

1) Right-click in the Chart or Sheet window.  
The system lists the configured test device in the current system.  

2) Choose a device to replace the one displayed.  

 

  Note: 

The device that the current chart does not support is in unvailable status (grey). 

 

3.16  Adding Wait Option in Test UEs 

Added in the test UEs in the configuration plan, the Wait is used to set the time interval 
between two test items. 
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Chapter 4  Installing the Probe 

4.1  Overview 

This chapter describes how to install the Probe.  

It contains the following contents: 

 Hardware Requirements 
 Installation Procedure 
 Installation Directory 
 Measures for Software Copyright Protection 

4.2  Hardware Requirements 

To run the Probe smoothly, ensure that the configuration of the PC meets the 
requirements listed in Table 4-1. 

Table 4-1 Hardware requirements 

Item Description 

CPU Pentium III 750 MHz at least 

Monitor VGA (1024 x 768, 16 bit color or higher) 

Memory  256 MB at least 

Hard disk 1 GB at least 

PC port 

 In the Probe, there should be at least one serial port, one parallel 
port, and one USB port. 

 A serial port connects to the GPS or Scanner, while a parallel port 
and an USB connect to the hard dongle and UE respectively.  

Operating 
system 

Windows 2000 or Windows XP 
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4.3  Hardware Equipment 

Table 4-2 Hardware equipment supported by the Probe 

Hardware Equipment Type 

UE 

 QUALCOMM TM6200 

 QUALCOMM TM6250 

 QUALCOMM TM6275 

 Huawei U626 

 Huawei U636 

 Huawei E600 data card 

 Huawei E620 data card 

 Commerical handset 

GPS antenna GPS complying with TAIP or NEMA0183 protocols 

Scanner 

 Anritsu’s Scanner 

 DTI Scanner 1800 M 

 DTI Scanner 1900 M 

 DTI Scanner 2100 M 

 

4.4  Installation Procedure 

For the Probe, the installation procedure contains: 

 Installing the Probe 
 Installing the GENEX Shared  

4.4.1  Installing the Probe 

To install the Probe, perform the following steps: 

1) Double-click setup.exe.  
The Preparing Setup dialog box is displayed, as shown in Figure 4-1. 
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Figure 4-1 Preparing Setup dialog box 

 

  Note: 

Click Cancel to exit.  

 

2) Enter the customer information in the Customer Information dialog box.  
3) Click Next, as shown in Figure 4-2. 
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Figure 4-2 Customer Information dialog box 

 

  Note: 

Click Back to return to the previous step. 

 

4) Choose the destination location in the Choose Destination Location dialog box, 
as shown in Figure 4-3. 
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Figure 4-3 Choose Destination Location dialog box 

5) Click Browse to choose the installation directory.  
6) Click Next. 

The Setup Status dialog box is displayed, as shown in Figure 4-4. 
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Figure 4-4 Setup Status dialog box 

7) Click Finish in the InstallShield Wizard Complete dialog box, as shown in 
Figure 4-5. 
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Figure 4-5 Completing the installation 

4.4.2  Installing the GENEX Shared 

As a public component package used for all the GEXEX series products, the GENEX 
Shared package contains the hard dongle driver, and several configuration 
components.  

Ensure that the GENEX Shared is correctly installed before running the Probe. The 
GENEX Shared is automatically installed after the installation of the Probe.  

If the GENEX Shared already exists, skip the GENEX Shared installation. 

  Note: 

 After Probe installation, the system will automatically start GENEX Shared 
component package installation.  

 If you uninstall the Probe, the GENEX Shared component package will not be 
uninstalled to ensure that other GENEX products can still work. You can, thus, skip 
GENEX Shared component package installation if it is already in the PCs.  

 However, if you upgrade the Probe, Huawei recommends that the GENEX Shared 
component package be installed again because GENEX Shared component may 
be upgraded at the same time. 
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4.5  Installation Directory 

After the installation of the Probe, the system forms an installation directory, as listed in 
Table 4-3. 

Table 4-3 Directory structure 

Directory Description 

Capture Saves captured images. 

Config Saves system configuration files 

Data Saves test data 

Log Saves system logs 

Voice Saves voice files 

Template project Saves project templates 

Documents Saves associated documents for the Probe 

 

  Note: 

Among all these directories, the \Capture, \Data, and \Log are automatically created 
during the first running of the system.  

 

4.6  Measures for Software Copyright Protection 

The hard dongle protects the Probe. Connect the hard dongle before using the Probe. 
The system checks the connection during the startup.  

Connect several hard dongles in series to use the GENEX series.  

Once the connection does not work or the license is invalid, the system prompts you to 
connect the hard dongle correctly or to update the license.  

 

  Note: 

When updating the license of the hard dongle, connect the hard dongle that needs 
updating rather than connect several dongles simultaneously. After updating the 
license, connect the rest hard dongles. 
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4.6.1  Viewing the License 

To view the license, perform the following steps: 

1) Choose Help > License Info… on the main menu. 
The License Info dialog box is displayed. 

2) View the license information. 

 

  Note: 

You can apply for the licenses based on the modules that you are to use. For example, 
the license for the HSDPA module can be applied for individually. 

 

4.6.2  Updating the License 

To update the license, perform the following steps: 

1) Check the license of hard dongle.  
2) Send the ESN in the license to the Huawei Customer Service Center to obtain the 

Probe license file. 
3) Enable the update license function, as shown in Figure 4-6. 

 

Figure 4-6 Update License dialog box 

4) Click Browse… and choose the directory of the update file. 
5) Click Update. 
6) Reboot the Probe to validate the updated license. 
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Chapter 5  Graphical User Interface 

5.1  Overview 

This chapter describes the user interface in the Probe. 

It contains the following contents: 

 Main Interface 
 System Configuration  
 View Window 

5.2  Main Interface 

The Graphical User Interface (GUI) in the Probe facilitates your operation.  

The main interface is displayed after the Probe is started, as shown in Figure 5-1. 

 

(1) Menu bar (2) Toolbar (3) Navigation tree 

(4) Work space (5) Status bar  

Figure 5-1 Main interface of the Probe 

5.2.1  Menu Bar 

I. File Menu 

The File menu enables operations on the project, as shown in Figure 5-2. 
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Figure 5-2 File menu 

For details about operations in File menu, refer to section 6.2  "Managing the Project 
Files." 

II. Logfile Menu 

The Logfile menu provides the operations on the drive test files, as shown in Figure 
5-3. 
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Figure 5-3 Logfile menu 

 For the playback of the logfile, refer to section 9.6  "Controlling the Log File 
Playback." 

 For the export of the logfile, refer to Chapter 11  "File Exporting Funtion." 
 For the shortcut keys, refer to Appendix A.”Common Parameters and Shortcuts.” 

The logfiles opened recently are listed on the menu. In this way, you can choose 
several drive test files recently used as your data source. 

III. Configuration Menu 

The Configuration menu provides the preparation operations for the Probe test, as 
shown in Figure 5-4.  

 

Figure 5-4 Configuration menu 
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To facilitate information searching, you can refer to the following suggestions: 

 For details about the hardware configuration, refer to section 6.4  "Configuring ." 
 For details about the information of Base Transceiver Station (BTS), refer to 

section 6.5  "Importing the Engineering Parameter." 
 For details about the Map Mark, refer to section 9.2  "Conducting a Test." 
 For details about the system configuration, refer to section 5.3  "System 

Configuration Window." 

IV. View Menu 

Figure 5-5 shows the items listed in the View menu. 

 

Figure 5-5 View menu 

For details about the View menu, refer to section 5.4  "View Window." 

V. Test Menu 

The Test menu provides controls on the drive test process, as shown in Figure 5-6. 
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Figure 5-6 Test menu 

For details about the Test menu, refer to section 9.2  "Conducting a Test." 

VI. Window Menu 

The Window menu enables window arranging and window opening, as shown in 
Figure 5-7. 

 
Figure 5-7 Window menu 

VII. Help Menu 

The Help menu provides the help information, as shown in Figure 5-8. 
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Figure 5-8 Help menu 

5.2.2  Toolbar 

The toolbar provides the buttons for system operations. 

I. Standard Toolbar 

Figure 5-9 shows the standard toolbar. 

 

Figure 5-9 Standard toolbar 

The standard toolbar contains some buttons for routine operations, as listed in Table 
5-1. 

Table 5-1 Buttons on the standard toolbar 

Button Description 

 To create a project 

 To open a project 

 To save a project 

 

To choose a device 

Note: 

Ensure that a device is selected before checking the 
parameter windows. 
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Button Description 

 

To search a device 

Note: 

The system searches a device and connects it to the COM port 
based on the hardware configuration of the project. 

 

To begin a test 

Note: 

The function takes effect only when the test device is 
available.  

 

To end a test 

Note: 

The function takes effect only when the test mode is in use. 

 

To pause or continue recording 

Note: 

The function takes effect only when the system records the 
logfile at the beginning of the drive test and the test mode is in 
use. 

 To pause or recover screen display 

 To capture a window 

 About the Probe 

 

II. Logfile Toolbar 

The logfile toolbar contains some common operations during the log file playback, as 
shown in Figure 5-10. 

 

Figure 5-10 Logfile toolbar 

Table 5-2 describes the buttons on the logfile toolbar. 
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Table 5-2 Buttons on the logfile toolbar 

Button Description 

 To open a log file 

 

To play a log file 

Note: 

The function takes effect only when the log file 
to be played is open. 

 To pause or continue playing 

 To stop a play 

 

To change the play direction 

Note: 

The Probe can play forward or backward. 

 

To lock a position 

Note: 

This function takes effect only when Event 
Browsing is selected. 

 

To adjust the play rate 

Note: 

The available range is from 1/8 to 8 times of 
rate. 

To adjust the play progress 

Note: 

The slider enables you to locate at any position 
of the log file. The function takes effect only 
when the log file is open. 

 

To set the play time 

Note: 

You can enter the time and press the blank key 
to set the broadcast time. The function takes 
effect only when the log file is open. 
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III. Map Toolbar 

The map toolbar, as shown in Figure 5-11, contains the icons for routine map 
operations and is available only when the Map window is open. 

 

Figure 5-11 Map toolbar 

Table 5-3 lists the descriptions of the buttons on the map toolbar. 

Table 5-3 Buttons on the map toolbar 

Button Description 

 To open a map 

 To save a map 

 To import a raster map 

 To set the map layer 

 To search for a cell 

 To zoom in a map 

 To zoom out a map 

 To select the zoom scale of map area 

 To span a map 

 To center a map 

 To select a map 



User Manual  
GENEX Probe Wireless Air Interface Testing Software Chapter 5  Graphical User Interface
 

Huawei Technologies Proprietary 

5-10 

Button Description 

 To select a map in rectangle 

 Map scale 

 

To lock an area 

Note: 

Choose the current position during correction. 

 To undo the current dots 

 To rotate the selected points during static correction 

 

IV. Indoor Measurement Toolbar 

The indoor measurement toolbar is used for routine operations on the indoor 
measurement map, as shown in Figure 5-12. 

 

Figure 5-12 Indoor measurement toolbar 

Table 5-4 describes the buttons on the indoor measurement toolbar. 

Table 5-4 Buttons on the indoor measurement toolbar 

Button Description 

 To import a raster map 

 

To dot a map 

Note: 

The drive test route is generated by dotting the map during the 
indoor test. 

 To zoom in a map 

 To zoom out a map 
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Button Description 

 To span a map 

 To select an area 

 To undo the previous step 

 

V. BTS Information Toolbar 

The BTS information toolbar is used to edit the BTS information, as shown in Figure 
5-13.  

 

Figure 5-13  BTS information toolbar 

Table 5-5 describes the buttons on the BTS information toolbar. 

Table 5-5 Buttons on the BTS information toolbar 

Button Description 

 To open the BTS information list 

 To save the BTS information 

 
To apply the edited BTS information to the system and save the 
project in the project files. 

 

VI. Device List Toolbar 

The device list toolbar is used for the operations on the device configuration, as shown 
in Figure 5-14. 

 

Figure 5-14 Device list toolbar 

Table 5-6 describes the buttons on the device list toolbar. 
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Table 5-6 Buttons on the device list toolbar 

Button Description 

 To add a device 

 To remove a device 

 To search for a device 

 

5.2.3  Navigation Tree 

I. Test Control Tab 

The Test Control tab contains some routine operation buttons used in the test, as 
shown in Figure 5-15. 

 

Figure 5-15 Test Control tab 

II. View Tab 

The View tab provides the function of system viewing. To view the items, double-click 
the items, as shown in Figure 5-16. 
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Figure 5-16 View tab 

III. Property Tab 

The Property tab displays the information about the current device in the device check 
box, as shown in Figure 5-17. 
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Figure 5-17 Property tab 

 

  Note: 

 If more than one device of the same type is connected to the Probe, choose the 
device you want on the Device list on the toolbar. Alternatively, choose the device 
in the device name drop-down list in the Property tab.  

 The system displays the associated parameters of the selected device in the 
Property window. 
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5.2.4  Work Space 

The work space contains all the open view windows. You can customize several work 
pages in the work space: 

 Press Alt+Z to define the window layout. 
 Press Alt+1, Alt+2, or Alt+3 to define the work space. 

For details about main interface operations, refer to section 6.3  "Managing the 
Workspace." 

5.2.5  Status Bar 

I. System Status Bar 

The system status bar contains four parts, as shown in Figure 5-18. The four parts are 
as follows: 

 Menu prompt 
 UE Radio Frequency (RF) mode 
 Probe status 
 Device status 

 

Figure 5-18 System status bar 

Table 5-7 describes the four parts on the system status bar. 

Table 5-7 Four parts on the system status bar 

Part Description 

Menu prompt To display the information about the current selected menu 

UE RF mode 

To display the current UE RF mode 

The UE RF mode contains: 

 GSM 

 WCDMA 

 Unknown 
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Part Description 

Probe status 

To display the current Probe status 

The status may be: 

 Idle 

 Real-time test 

 Log file playback 

Note: 

The system tells you the current status you are in. If you 
place the mouse on the Probe status bar, the system shows 
the name of the open log file. 

Device status 

To display the status of device connection 

 Red light indicates that the device is disconnected or 
faulty. 

 Green light indicates that the device is connected 
properly. 

 Yellow light indicates that the satellites are not enough. 

Note: 

Put the mouse on the device status, the system shows what 
the current light stands for. Double-click the indicator to 
open a tab. 

 

II. Legend Status Bar 

The legend status bar displays the layer information currently used in the Probe, as 
shown in Figure 5-19. 
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Figure 5-19 Legend status bar 

III. Map Status Bar 

The map status bar displays the related map information, as shown in Figure 5-20. 

The map status bar consists of the following parts: 

 Map ruler 
 Correction status 
 Map scale 
 Longitude and latitude 

 

Figure 5-20 Map status bar 

Table 5-8 describes each part on the map status bar. 

Table 5-8 Parts on the map status bar 

Part Description 

Map ruler To display the distance between two points 

Correction status To display if it is in correction state 

Map scale To display the map scale 
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Part Description 

Longitude and 
latitude 

To display the longitude and latitude of a position in the 
map window 

 

5.3  System Configuration Window 

To open the system configuration window, choose Configuration > System Config. 
The System Configuration Properties window consists of the following tabs: 

 Test Plan 
 LogMask 
 Event 
 Alarm 
 Other  

5.3.1  Test Plan 

The Test Plan tab contains the test items and parameters triggered by the UE and the 
Scanner, as shown in Figure 5-21. 

 

Figure 5-21 Test Plan dialog box 
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  Note: 

For details about the operations in the Test Plan window, refer to part 6.7.1  "Setting 
a Test Plan." 

 

5.3.2  LogMask 

The LogMask tab sets the filtering configuration for the data collected during the drive 
test, as shown in Figure 5-22. 

 

Figure 5-22 LogMask dialog box 

 

  Note: 

 Do not change the default settings if you are not familiar with the Probe. 
 For details about the operations in the LogMask window, refer to part 6.7.2  

"Setting the Log Mask." 

 

5.3.3  Event 

The Event tab is used for the display, prompts, icons, voices, and configurations of all 
the events occurred in the radio network, as shown in Figure 5-23.  
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Figure 5-23 Event dialog box 

 

  Note: 

For details about the operations in the Event window, refer to part 6.7.3  "Setting the 
Event." 

 

5.3.4  Alarm 

The Alarm tab is used to give prompts if errors occur, as shown in Figure 5-24. 
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Figure 5-24 Alarm dialog box 

 

  Note: 

For details about the operations in the Alarm window, refer to part 6.7.4  "Setting the 
Alarm." 

 

5.3.5  Other 

Figure 5-25 shows the Other tab. For details about the operations in the Other window, 
refer to part 6.7.5  "Setting Other." 
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Figure 5-25 Other dialog box 

5.4  View Window 

The View window consists of 

 Parameter Window 
 WCDMA Parameter Chart 
 GSM/GPRS Parameter Chart 
 Message Parameter Chart 
 Anritsu Scanner Parameter Chart 
 DTI Scanner Parameter Chart 
 Data Service Parameter Chart 
 AMR Window 
 Event List Window 
 UE State Window 
 Information Window 
 Map Window 
 Indoor Measurement Window 
 Window Templates 

5.4.1  Parameter Window 

The Probe Parameter window displays all the information about the selected device. 
For details about operations in the Probe Parameter window, refer to part 6.3.2  
"Adding a Pane to a Tab." 
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I. Chart 

  Caution: 

If the chart view is changed to the list view, all the information and settings in the chart 
view are lost. 

 

The Chart window shows the trends of data. Many kinds of charts are available, 
including: 

 Active set chart 
 Power chart 
 HSDPA physical link chart 
 HSDPA rate chart 

Some routine operations in the chart are as follows: 

 Click and drag the box to zoom in or restore the scale of the chart. 
 Right-click and drag the chart to move the chart up, down, left, and right. 
 Right-click the chart and choose a certain option to move the chart. 

Table 5-9 lists the options on the shortcut menu of the chart. 

Table 5-9 Options on the shortcut menu of the chart 

Option Description 

Device 

To display the parameters of the current chart. 

Those devices that are not supported by the current chart are in gray, 
indicating unavailability, as shown in Figure 5-26. 

Legend To select or clear some legend boxes, as shown in Figure 5-27. 

Color 
To set the color and font of each parameter, as shown in Figure 5-28 
and Figure 5-29. 

SetTitle To set the title for a custom window. 

Custom 
To display the ChartView Custom Properties dialog box. You can 
change the properties of the chart display by adjusting the values in the 
dialog box, as shown in Figure 5-30. 

List view To convert the chart view into the list view. 
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Figure 5-26 Device option 

 

Figure 5-27 Legend option 
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Figure 5-28 Color option 

 
Figure 5-29 Legend Color Edit dialog box 
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Figure 5-30 ChartView Custom Properties dialog box 

II. List 

The list window shows the real-time change of certain parameters in text. These 
parameters are as follows: 

 Network parameter 
 Cell parameter 
 HSDPA physical channel parameter 

 

  Note: 

The legend color depends on the color of the parameter displayed in the Chart 
window. That is, the Probe applies the parameter color to the legend in the window. 

 

III. Chart and List 

The list can display the accurate values of each indicator in numbers or characters 
directly, while the chart reflects the trend of the changes in the indicator vividly, as 
shown in Figure 5-31. 
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Figure 5-31 Chart and list 

5.4.2  WCDMA Parameter Chart 

I. Power Control 

As shown in Figure 5-32, this Power Control window displays the following 
information: 

 UE reception power 
 UE transmission power 
 Signal-to-Interference Ratio (SIR) 
 Transmit Power Control (TPC) 
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Figure 5-32 Power Control window 

 

  Note: 

 The UE Tx TPC refers to the command of power control on the NodeB by the UE. 
The command consists of two bytes (one frame), with 15 effective bits 
corresponding to power control value of each time slot. 0 stands for lowering a step, 
while 1 represents enhancing a step. The Probe summarizes the values of the 15 
bits and displays the final results as final power control value. (0 equals to –1 
during the value addition). 

 The Cell Tx TPC refers to the command of power control on the UE by the NodeB. 
The command consists of two bytes (one frame), with 15 effective bits. The 
calculation method in Cell Tx TPC is similar to that in UE Tx TPC. 

 

II. WCDMA BLER 

The WCDMA BLER window displays the downlink Block Error Rate (BLER) based on 
transport channels. To be specific, the WCDMA BLER window mainly displays: 

 BLER in the connected state or during the call 
 BLER on the Paging Channel (PCH) or Forward Access Channel (FACH) in the 

disconnected state 
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The BLER takes effect only during call setup or call connection, as shown in Figure 
5-33.  

 
Figure 5-33 WCDMA BLER window 

 

  Note: 

The WCDMA BLER window shows the downlink BLER of the A-DCH channel when 
the HSDPA is used to bear the service. 

 

III. Cell Search 

The Cell Search window displays the parameter information of each step during cell 
search, as shown in Figure 5-34. The information is visible only after the associated 
item in the LogMask is selected. 
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Figure 5-34 Cell Search window 

IV. Serving/Active Set & Neighboring Cells 

As shown in Figure 5-35, this Serving/Active Set & Neighboring Cells window 
displays the following information of the UE: 

 Active set 
 Monitor set 
 Detected set 
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Figure 5-35 Serving/Active Set & Neighboring Cells window 

Table 5-10 lists some operations in the Serving/Active Set & Neighboring Cells 
chart. 

Table 5-10 Operations in the serving/active set & neighboring cells chart 

To… You can… 

Check the Ec/Io trend Refer to the upper right chart. 

Check the real-time Ec/Io Refer to the lower right chart. 

Check what set the scrambling codes 
belong to 

Right-click the chart and choose a 
legend on the shortcut menu. 

 

Table 5-11 lists the implications of each legend on the shortcut menu. 

Table 5-11 Legend implications 

Legend Implication 

Rectangle Active set data 
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Legend Implication 

Circus Monitor set data 

Triangle Detected set data 

 

The scrambling codes of the data of the same shape can be distinguished from each 
other by different colors. 

To distinguish scrambling codes by color, perform the following steps: 

1) Right-click in the Serving/Active Set & Neighboring Cells window. 
2) Choose Custom on the shortcut menu. 
3) Set Mark Tip Tool to True. 
4) Click OK. 
5) Move the mouse to a place to get the scrambling information of the current point. 

 

  Note: 

When the UE is in idle state, the first information must be about the cell where the UE 
resides. 

 

V. Finger 

The Finger window indicates the finger information of the UE, as shown in Figure 
5-36. 

 

Figure 5-36 Finger window 
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VI. RACH and PRACH 

The RACH And PRACH window displays the random access parameters of the UE 
only when the LogMask is customized, as shown in Figure 5-37. 

 

Figure 5-37 RACH And PRACH window 

VII. DRX Mode 

The DRX Mode window displays the discontinuous reception parameters of the UE, 
as shown in Figure 5-38. 
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Figure 5-38 DrxMode window 

VIII. Transport Channel 

The Transport Channel window displays the parameters on the transport channel in 
the uplink and downlink, as shown in Figure 5-39. 

 
Figure 5-39 Transport Channel window 
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IX. Physical Channel 

The Physical Channel window displays the parameters on the physical channel. As 
shown in Figure 5-40, the physical channel falls into the following types: 

 Physical Channel Uplink 
 Common Physical Channel Downlink 
 Dedicate Physical Channel Downlink 

 

Figure 5-40 Physical Channel dialog box 

X. RM UL 

The RM UL window displays the parameter information about rate matching uplink. As 
shown in Figure 5-41, the information consists of two parts: 

 Transport Format Combination Indicator (TFCI) 
 Transport channel 
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Figure 5-41 RM UL window 

XI. Inter-RAT GSM Cell Information 

The Inter-RAT GSM Cell Information window displays the GSM cell information 
tested in the WCDMA mode, as shown in Figure 5-42. 

 

Figure 5-42 Inter-RAT GSM Cell Information window 

XII. WCDMA HSDPA Physical Channel 

The WCDMA HSDPA Physical channel window displays the configuration 
parameters on the HSDPA channel, as shown in Figure 5-43. 
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Figure 5-43 WCDMA HSDPA Physical channel window 

Table 5-12 describes the parameters in the WCDMA HSDPA Physical channel 
window. 

Table 5-12 Parameters in the WCDMA HSDPA Physical channel window 

Parameter Description 

HS Serving Cell PSC 
Primary cell code of the HSDPA serving 
cell 

H-RNTI UE ID ID number of the H-RNTI UE 

DL DPCH to HS-SCCH Timing Offset 
Time offset between the DL DPCH and 
the HS-SCCH 

HARQ Processes HARQ process 

HS-SCCH 
Number of the HS-SCCH and its 
effectiveness 

OVSF Orthogonal variable spreading factor 

CQI Feedback Cycle Feedback cycle of the CQI 

CQI Repetition Factor Repetition factor of the CQI 
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Parameter Description 

Ack/Nack Repeatition Factor Repeatition factor of the Ack/Nack 

UL DPCH to HS-DPCCH Timing Offset 
Timing offset between the L DPCH and 
the S-DPCCH 

PO-ACK 
Power offset between the CK and the 
S-DPCCH 

PO-NACK 
Power offset between the ACK and the 
S-DPCCH 

PO-CQI 
Power offset between the CQI and the 
S-DPCCH 

MAC-d Flow ID ID of the flow 

CCTrCHID 
ID of the code combination transmit 
channel 

Queue ID List List of queue ID 

Queue ID ID of the queues 

Receive Window Size 

The range of the SN in the Mac-hs PDU 
received from the Mac-hs entity can be 
represented by a slider. Having received 
the Mac-hs PDU, the slider moves 
forword. 

The Receive Window Size refers to the 
available part of the slider. 

Note: 

TSN: Transmission Sequence Number 

Reordering Release Timer 

The reordering release timer is enabled 
when the discontinuous Mac-hs PDU is 
received by the Mac-hs entity. 

If all the Mac-hs PDU cannot be 
received completely before the timeout, 
the Probe submits the Mac-hs PDU to 
the upper layer for data retransmission. 

MAC-d PDU Sizes Sizes of the MAC-d PDU 
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XIII. WCDMA HSDPA Link Statistics 

The WCDMA HSDPA Link Statistics window displays the following information, as 
shown in Figure 5-44. 

 HSDPA throughput 
 HSDPA BLER 
 HSDPA channel utilization 
 HSDPA channel quality 
 HSDPA code occupancy 

 
Figure 5-44 WCDMA HSDPA Link Statistics window 

Table 5-13 describes the parameters in the HSDPA Link Statistics window. 

Table 5-13 Parameters in the HSDPA Link Statistics window 

Parameter Description 

Scheduled Rate – Delta 
Instantaneous rate that the MAC layer 
schedules 

Scheduled Rate – Average 
Average rate that the MAC layer 
schedules 
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Parameter Description 

Served Rate – Delta 

Instantaneous rate at which the MAC 
layer transmits 

The transmission here contains: 

 Transmission failure 

 Re-transmission 

Served Rate – Average 

Average rate at which the MAC layer 
transmits 

The transmission here contains: 

 Transmission failure 

 Re-transmission 

MAC Layer Rate – Delta 

Instantaneous rate at which the MAC 
layer transmits 

The transmission here excludes: 

 Transmission failure 

 Re-transmission 

MAC Layer Rate – Average 

Average rate at which the MAC layer 
transmits 

The transmission here excludes: 

 Transmission failure 

 Re-transmission 

HS-SCCH Success Rate – Delta 
Schedule success rate of the HS-SCCH 
channel 

HS-SCCH Success Rate – Average 
Average schedule success rate of the 
HS-SCCH channel 

HS-DSCH SBLER – Delta 

Instantaneous BLER of the MAC layer 

SBLER = Number of NACK/(Number of 
ACK + Number of NACK) (in the period of 
200 ms) 

HS-DSCH SBLER – Average 

Average BLER of the MAC layer 

SBLER = Number of NACK/(Number of 
ACK + Number of NACK) 
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Parameter Description 

HS-DSCH Res. BLER – Delta 

Instantaneous BLER of the RLC layer 

Note: 

In the event that the MAC layer cannot 
perform transmission successfully after 
several retransmissions, the RLC 
originates the re-transmission. 

HS-DSCH Res. BLER - Average 

Average BLER of the RLC layer 

Note: 

In the event that the MAC layer cannot 
perform transmission successfully after 
several retransmissions, the RLC 
originates the re-transmission. 

HS-DSCH Retrans.Rate - Delta 

Instantaneous retransmission rate of the 
HS-DSCH channel 

HS-DSCH Retrans.Rate - Delta = 
Number of retransmission frames in the 
period of 200 ms/Number of new 
transmission frames 

HS-DSCH Retrans.Rate - Average 

Average retransmission rate of the 
HS-DSCH channel 

HS-DSCH Retrans.Rate - Average = 
Number of retransmission 
frames/Number of new transmission 
frames 

CQI Average CQI in the period of 200 ms 

Number of HS-PDSCH Codes 
Average HS-PDSCH code count in the 
period of 200 ms 

 

The WCDMA HSDPA Link Statistics and the WCDMA HSDPA Decoding Statistics 
windows support the function of data clearance. To do this, perform the following 
steps: 

1) Right-click in the HSDPA Link Statistics or the HSDPA Decoding Statistics 
window. 

2) Choose Clear on the shortcut menu. 
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The data in the two windows are cleared at the same time. That is, if you clear the data 
in one window, the data in the other window is also cleared. 

 

  Note: 

Delta in the parameters mentioned previously stands for the average value in the 
period of 200 ms, while the Average represents the average value of all the data. If the 
data in the window is cleared, the Average stands for the average value after the 
clearance. 

 

XIV. WCDMA HSDPA Decoding Statistics 

The WCDMA HSDPA Decoding Statistics window displays the associated indicators 
about the decoding on the HS-SCCH channel and the HS-DSCH channel, as shown in 
Figure 5-45. 

 

Figure 5-45 WCDMA HSDPA Decoding Statistics window 

Table 5-14 describes the parameters in the WCDMA HSDPA decoding statistics. 

Table 5-14 Parameters in the WCDMA HSDPA decoding statistics 

Parameter Description 

HS-SCCH Attempts Total number of frames 



User Manual  
GENEX Probe Wireless Air Interface Testing Software Chapter 5  Graphical User Interface
 

Huawei Technologies Proprietary 

5-43 

Parameter Description 

HS-SCCH Successes Number of HS-SCCH frames scheduled to the local UE 

HS-SCCH Success Rate HS-SCCH channel utilization 

ACK-NACK/DTX 
(Duplicate) 

Ratio of retransmission of the correct frame 

TBS 
Transport block size 

Each frame transmits one TB. 

QPSK 
Number of frames with Quadrature Phase Shift Keying 
(QPSK) modulation 

16QAM 
Number of frames with 16 Quadrature Amplitude 
Modulation (QAM) 

SB - 
Number of frames transmitted unsuccessfully on the 
MAC layer 

SB + 
Number of frames transmitted successfully on the MAC 
layer 

Dup. SB + Number of the retransmission of the same frames 

Other 

Number of frames unconventional 

For example, the frame whose TBS is different in 
different periods is considered unconventional. 

SBLER 

BLER on the MAC layer 

Calculated by: 

Transmission failures/Total transmission 

1st BLER 
BLER in the retransmission of the first frame on the MAC 
layer 

Block - 

Frames transmitted unsuccessfully on the RLC layer 

The RLC originates the re-transmission after several 
failures in the MAC layer. In such a situation, the frame 
number should be added with 1. 

Block + 
Frames transmitted successfully on the RLC layer 

Block + equals to SB +.  
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Parameter Description 

Res. BLER 

BLER on the RLC layer. 

Calculated by: 

(Block -)/ [(Block -) + (Block +)] x 100% 

1 
Number of frames transmitted successfully in the first 
transmission 

2 
Number of frames transmitted successfully in the second 
transmission when the first transmission fails 

3 
Number of frames transmitted successfully in the third 
transmission when the first and the second transmission 
fail 

4 
Number of frames transmitted successfully in the fourth 
transmission when the first three transmissions fail 

5 

Number of frames transmitted successfully in the fifth 
transmission when the fisrt four transmissions fail 

Note: 

The first to the fourth transmissions experience the 
failure. The fifth retransmission is originated by the RLC 
layer because of the HARQ set in the Huawei device. 

>=6 

Number of frames transmitted successfully after the fifth 
transmission 

Note: 

After the first retransmission, the frame goes through at 
least four retransmissions before being successfully 
transmitted. 

 

XV. Active Set PSC Strength 

The Active set PSC strength window displays the information about the UE link. The 
UE link contains: 

 Service link 
 Signaling link 

The Active set PSC strength window shows the following information, as shown in 
Figure 5-46. 
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 How many radio links are available to the UE, namely, how many cells are 
available in the active set. 

 Which cell supports the HSDPA service. 
 Which cell provides signaling link. 

 

Figure 5-46 Active set PSC strength window 

5.4.3  GSM/GPRS Parameter Chart 

I. Cell Parameter, Channel Parameter, Hopping Parameter 

The Cell Param, Channel Param, Hopping Param window displays the information 
about cell parameters, channel parameters, and hopping parameters, as shown in 
Figure 5-47. 
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Figure 5-47 Cell Param, Channel Param, Hopping Param window 

II. GSM Serving and Neighboring Cells 

The GSM Serving and Neighboring Cells window displays the serving cells and 
neighboring cells of the UE, as shown in Figure 5-48. 

 

Figure 5-48 GSM Serving and Neighboring Cells window 
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III. GSM CCCH Parameter, RACH Parameter, and Reselect Parameter 

As its name indicates, the GSM CCCH Param And RACH Param And Reselect 
Param window displays the following information, as shown in Figure 5-49. 

 GSM Common Control Channel (CCCH) parameter 
 Random Access Channel (RACH) parameter 
 Reselect parameter 

 

Figure 5-49 GSM CCCH Param And RACH Param And Reselect Param window 

IV. Radio Parameter 

The Radio Parameter window displays the received signal level and transmitted 
power level of each cell, as shown in Figure 5-50. 
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Figure 5-50 Radio Parameter window 

V. BA List 

The BA List window displays the basic access (BA) cell list and all the detected 
neighbor cells, as shown in Figure 5-51. 
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Figure 5-51 BA List window 

VI. 3G Neighbour Cell Measurement 

The 3G Neighbor Cell Measurement window displays the 3G neighbor cell 
parameters measured in the 2G network, as shown in Figure 5-52. 

 

Figure 5-52 3G Neighbor Cell Measurement window 
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VII. GSM Cell Selection and Reselection Param 

The GSM Cell Selection And Reselection Param window displays the parameters 
about the cell selection and reselection, as shown in Figure 5-53. 

 

Figure 5-53 GSM Cell Selection And Reselection Param window 

5.4.4  Message Parameter Chart 

I. MAC/RLC Messages 

The MAC/RLC Messages window displays the messages about the Media Access 
Control (MAC) and Radio Link Control (RLC). That is, the MAC/RLC Messages 
window shows the signaling and parsing on the layer2, as shown in Figure 5-54. The 
messages are visible only when the associated items in LogMask are selected. 
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Figure 5-54 MAC/RLC Messages window 

To operate the MAC/RLC Messages window, perform the following steps: 

1) Right-click in the MAC/RLC Messages window.  
The shortcut menu is displayed, as shown in Figure 5-55. 

 

Figure 5-55 Shortcut menu of the MAC/RLC Messages window 

2) Choose Messages Filter. 
The messages filter is displayed on the left of the window. 

3) Choose Auto Scroll to conduct scrolling automatically. 

 

  Note: 

This shortcut menu is applicable to all the messages windows. 
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II. RRC Messages 

The RRC Messages window displays the essential layer 3 messages.  

Where, 

 All the UEs or single UE are displayed on the window. 
 The messages selected on the left navigation tree are displayed, as shown in 

Figure 5-56. 
 The detailed information is displayed by double-clicking the message, as shown 

in Figure 5-57. 

 

Figure 5-56 RRC Messages window 
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Figure 5-57 Rrc Connection Setup Complete window 

III. GSM RR Messages 

The GSM RR Messages window displays GSM radio resource messages, as shown 
in Figure 5-58 and Figure 5-59. The operation of this window is the same as that of the 
RRC Messages window. 
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Figure 5-58 GSM RR Messages window 

 

Figure 5-59 System Information Type5ter window 
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IV. NAS Messages 

The NAS Messages window displays the NAS messages, as shown in Figure 5-60 
and Figure 5-61. The operation is the same as that of the RRC Messages window. 

 

Figure 5-60 NAS Messages window 
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Figure 5-61 NAS OTA MESSAGE window 

5.4.5  Anritsu Scanner Parameter Chart 

I. Scanner Channel Info 

The Scanner Channel Info window displays the scrambling code information and 
relevant parameters of each cell, as shown in Figure 5-62. 
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Figure 5-62 Scanner Channel Information window 

II. Scanner Finger Info 

The Scanner Finger Info window displays the finger information of a scramble code, 
as shown in Figure 5-63. 

 

Figure 5-63 Scanner Finger Info 
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5.4.6  DTI Scanner Parameter Chart 

I. TopN Pilot 

If you set Enable to True in the TopN pilot scan of the DTI Scanner test plan and set 
the frequency to be scanned, the TopN Pilot window displays the TopN scrambling 
codes and their Ec/Io and RSCP, as shown in Figure 5-64. 

 

Figure 5-64 TopN Pilot window 

  Note: 

 In Figure 5-64, the X-axis represents the scrambling codes. 
 The green histogram stands for Ec/Io, while the red one for RSCP. 

 

Right-click in the TopN Pilot window and choose an indicator to be displayed, as 
shown in Figure 5-65. 
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Figure 5-65 Shortcut menu of the TopN pilot window 

 

  Note: 

If the multi-frequency points are set in the measurement plan, right-click in the TopN 
Pilot window and choose the point to be displayed. 

 

II. Spectrum Analysis 

If you set Enable to True in the spectrum analysis of the DTI Scanner test plan, the 
Spectrum Analysis window displays the result of the spectrum analysis, as shown in 
Figure 5-66. 
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Figure 5-66 Spectrum Analysis window 

 

  Note: 

If there are no curves available in the window, it indicates that errors occur in the 
setting of the frequency range. 

 

III. CW Test  

If you set Enable to True in the CW test and Enable to False in the other test items of 
the DTI Scanner test plan, the CW Test window displays the CW signals. 

The CW Test window can be displayed in two modes: 

 Real-time chart 
 Trend chart 

Figure 5-67 is a trend chart, displaying the change of CW signal strength with time. 
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Figure 5-67 CW Test window 

 

  Note: 

Right-click in the CW Test window and choose to convert the display mode. 

 

IV. Pilot 

If you set Enable to True in the pilot scan of the DTI Scanner test plan, and set the 
frequencies and scrambling codes to be scanned, the Pilot window displays the 
measurement value of these specified scrambling codes. 

The options and their implications in the Pilot window are similar to that in the TopN 
Pilot window. The difference lies in that the Scanner information of the specified 
scrambling codes is displayed, as shown in Figure 5-68. 
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Figure 5-68 Pilot window 

V. SCH Scan 

If you set Enable to True in the SCH scan of the DTI Scanner test plan, the SCH Scan 
window displays the parameters in the synchronization channel, as shown in Figure 
5-69. 

 

Figure 5-69 SCH Scan window 

VI. RSSI 3.84M 

If you set Enable to True in the RSSI 3.84 M of the DTI Scanner test plan, the RSSI 
3.84M window displays the received signal strength indicator of the specified 
UARFCN. You can observe the real-time change of the signal strength, as shown in 
Figure 5-70.  
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Figure 5-70 RSSI 3.84M window 

5.4.7  Data Service Parameter Chart 

I. App Throughput 

The App Throughput window displays the following information: 

 Uplink and downlink rate on the application layer 
 NAS rate 
 TCP retransmission rate 

The rate includes the statistics of all the applications in the operating system, as 
shown in Figure 5-71. 
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Figure 5-71 APP Throughput window 

II. RLC Throughput 

The RLC Throughput window displays the following information, as shown in Figure 
5-72. 

 RLC uplink throughput 
 RLC downlink throughput 
 Uplink PDU retransmission ratio 
 Downlink PDU error ratio 
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Figure 5-72 RLC Throughput window 

 

  Note: 

Different items can be displayed based on the icons selected on the shortcut menu.  

 

III. PS Common Indicators 

The PS Common Indicators window displays the common indicators in the PS 
domain.  

As shown in Figure 5-73, these common indicators consist of: 

 Attach success rate 
 Attach time 
 PDP context activation success rate 
 PDP context activation time 
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Figure 5-73 PS Common Indicators window 

IV. PING Service Quality Evaluation 

The PING Service Quality Evaluation window displays the associated indicators on 
the user plane of the PING service.  

Figure 5-74 shows the indicators in the PING Service Quality Evaluation window. 

 

Figure 5-74 PING Service Quality Evaluation window 
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V. HTTP Service Quality Evaluation 

The HTTP Service Quality Evaluation window displays the associated indicators on 
the user plane of the HTTP service, as shown in Figure 5-75. 

These indicators may be: 

 Page access time 
 Page download time 
 Average rate 
 QoS 

 
Figure 5-75 HTTP Service Quality Evaluation window 

VI. FTP Service Quality Evaluation 

The FTP Service Quality Evaluation window displays the associated indicators on 
the user plane of the FTP service, as shown in Figure 5-76. 

These indicators may be: 

 Login time 
 File directory time 
 Download and upload time 
 Download and upload average rate 
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 QoS 
 Duration of real-time transmission 

 

Figure 5-76 FTP Service Quality Evaluation window 

VII. Video Streaming 

The Probe can display some video streaming files with .rm or .3gp formats in real time 
when the RealPlayer and relevant decoding plugs are installed. 

5.4.8  AMR Window 

The AMR window is displayed when the AMR is selected in the LogMask. As shown in 
Figure 5-77, the AMR chart displays the following information: 

 Uplink and downlink vocoder data 
 Frame type 
 Frame rate 
 TAF 
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Figure 5-77 AMR window 

5.4.9  Event List Window 

The Event List window displays all the predefined events in the system, as shown in 
Figure 5-78. 

In actual measurement, these events can be displayed based on All UE or the 
specified UE. You can also select some items to be displayed in the left filter tree. Both 
the actual measurement events and the playback events are displayed in the Event 
List chart in the real-time manner. You can stop scrolling by selecting a certain option 
from the shortcut menu. 
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Figure 5-78 Event List window 

The Event List window can be co-activated with the signaling, maps or charts.  

 The information of the event parameters is displayed at once. 
 The geographic information is also displayed. 
 If Re-judge Event is selected in the system configuration, the event is 

re-generated in the playback based on the original data. 

5.4.10  UE State Window 

The UE State window displays the UE network parameters and their states. As shown 
in Figure 5-79, this window consists of the following three areas: 

 NAS 
 WCDMA 
 GSM 
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Figure 5-79 UE State window 

5.4.11  Information Window 

The Information window displays the real-time statistics and the log file information, 
as listed in Table 5-15.  

Table 5-15 Descriptions of the three tabs in the Information window 

Tab Description 

Statistic 
Gives the statistics of the each test item during the real-time 
measurement 

Log File 
The events in the Log File tab can be displayed only when 
Event Browsing is selected, as shown in Figure 5-80. 

UE1 

During the real-time measurement, the information about a 
device is displayed in the UE1 tab, as shown in Figure 5-81.

Note: 

The UE1 tab only takes effect during the real-time 
measurement, and displays all the proper and effective test 
plans for the UE1. 
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Figure 5-80 Log File tab 

 
Figure 5-81 UE1 tab 

5.4.12  Map Window 

As shown in Figure 5-82, the Map window displays the following information: 

 Digit map currently imported (For details, refer to section 6.6  "Importing a Map." 
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 Drive test path, imported sites and cells based on the GPS (For details, refer to 
section 6.5  "Importing the Engineering Parameter." 

 

Figure 5-82 Map window 

You can add, delete, or edit the map layers and legends in the May Layers pane. For 
details, refer to section 9.3  "Outdoor Test." 

Figure 5-83 shows the shortcut menu of the Map window. 
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Figure 5-83 Shortcut menu of the map window 

Table 5-16 describes the options on the shortcut menu. 

Table 5-16 Options on the shortcut menu 

Option Description 

Layer bar 
Select Layer Bar. The Map Layers pane is displayed on 
the right of the Map window. Otherwise, the pane is hidden.

Layer control 

Choose Layer Control. The Layer Control dialog box is 
displayed, as shown in Figure 5-84. 

Note: 

You can add, remove, or set properties for the layer in the 
Layer Control dialog box. 

Projection 
Select Projection. The Choose Projection dialog box is 
displayed, as shown in Figure 5-85. 

Previous view To check the previous view. 

Entire map 
To check the entire map of the layer. If serveral layers are 
available, you need to select a layer to be displayed, as 
shown in Figure 5-86. 
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Option Description 

Auto Center To center the map automatically. 

GPS Option 

Choose the signal source for the GPS. 

Figure 5-87 shows the possible GPSs: 

 External GPS only 

 Internal GPS only 

 Auto Adjust by Internal 

Enable adjustment To enable the GPS adjustment mode. 

Exit adjustment To exit the GPS adjustment mode. 

Adjustment option 

To choose the ranges for the adjustment. 

These ranges are: 

 All GPS 

 DR GPS only 

Offset angle 

Enter the offset angle in the dialog box, as shown in Figure 
5-88. 

For details, refer to section 9.3  "Outdoor Test." 

Enable static 
adjustment 

To enable the static adjustment mode. 

For details, refer to section 9.3  "Outdoor Test." 

Apply static 
adjustment 

To apply the static adjustment data. 

Tool 
To provide shortcut keys for the operations in the Map 
window. 
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Figure 5-84 Layer Control dialog box 

 

Figure 5-85 Choose Projection dialog box 
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Figure 5-86 Select Layer dialog box 

 
Figure 5-87 GPS submenu 

 
Figure 5-88 Offset Angle of Adjustment dialog box 

5.4.13  Indoor Measurement Window 

The Indoor Measurement window displays the indoor map currently imported, as 
shown in Figure 5-89. 
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Figure 5-89 Indoor Measurement window 

Figure 5-90 shows the shortcut menu of the Indoor Measurement window. 

 

Figure 5-90 Shortcut menu of the indoor measurement window 

Table 5-17 describes the options on the shortcut menu. 

Table 5-17 Options on the shortcut menu 

Option Description 

Vertical test To enable the vertical test. 
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Option Description 

Walking test 
To enable the walking test. 

The walking test can be automatic or manual. 

Layer bar 
Choose Layer Bar and the system displays the Map Layers pane 
on the right of the Map window. Otherwise, the pane is hidden. 

Entire map 
To check the entire map of the layer. In case of server layers 
available, you need to select the layer to be displayed. 

Localizer 
To dot the drive test line on the map and select report points on the 
map. 

Arrow To enter the arrow mode. 

Zoom in Choose Zoom In, and click the map to zoom in it. 

Zoom out Choose Zoom Out, and click the map to zoom out it. 

Pan Choose Pan, and click the map and drag it. 

Undo To cancel the previous operation. 

 

5.4.14  Window Templates 

The system provides the following four types of window template: 

 Window 1-1 
 Window 1-2 
 Window 2-2 
 Window 3-2 

Table 5-18 describes the window templates. 

Table 5-18 Window templates 

Template Description 

Window 1-1 Single window display mode (chart view or list view) 

Window 1-2 
Double window display mode (one chart view window and one list 
view window) 

Window 2-2 
Four windows display mode (two chart view panes and two list view 
panes) 
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Template Description 

Window 3-2 
Six windows display mode (three chart view panes and three list 
view panes) 

 

  Note: 

 Using window templates, you can display different parameters in various panes. 
 Set the display parameter before using the custom window templates. In this way, 

the reported data can be displayed. 
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Chapter 6  Managing the Project 

6.1  Overview 

During the drive test, conduct settings on the test project after the project is created or 
open. 

It contains the following contents: 

 Managing the Project Files 
 Managing the Workspace 
 Configuring a Device 
 Importing the Engineering Parameter 
 Importing a Map 
 Setting the System 

6.2  Managing the Project Files 

A test project can not only save some individual information, but also keep all the 
system configuration information.  

The individual information contains: 

 Window layout 
 Custom parameters 

The system configuration information contains: 

 BS information 
 Map legend 
 Test plan 
 LOGMASK setup 
 Event log setup 
 Alarm setup 
 Parameter setup 

Each test project corresponds to a project file in .xls format. 

 

  Note: 

The test plan can be saved either in the engineering file or individually. 
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6.2.1  Creating a New Project 

To create a new project, choose File > New Project.  

6.2.2  Saving a Project 

To save an open project, chose File > Save. 

All the system and individual settings are automatically saved into the project file. 

6.2.3  Opening a Project 

To open a project, choose File > Open Project.  

All the system and individual settings are automatically imported into the project file. 

 

  Note: 

You can also utilize the configurations used before to ensure the consistency of 
different tests. 

 

6.2.4  Loading a Project Template 

The Probe customizes and loads the templates for the test projects. 

To load the project template, perform the following steps: 

1) Choose File > Template Project. 
The Template List dialog box is displayed. 

2) Click a project template. 
The system loads the template automatically. 

 

  Note: 

 The Template Project file stores both the default and custom project templates. 
 At present, the Probe only displays the top10 project template files sorted in the 

alphabetic descending order. 
 During the tests on the similar projects, you can open the appropriate project 

template directly rather than reset the project. 

 

6.2.5  Closing a Project 

To close a project, choose File > Close Project. 
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The Information dialog box is displayed, querying if you would like to save the current 
setting in the Template Project file, as shown in Figure 6-1. 

 

Figure 6-1 Information dialog box 

6.3  Managing the Workspace 

The effective management and operation is fundamental to improve the test efficiency.  

6.3.1  Managing a Tab 

The data or the chart can be individually displayed in each tab.  

Figure 6-2 shows the shortcut menu of a tab. 

 

Figure 6-2 Shortcut menu of a tab 

Table 6-1 lists the descriptions of tab operations. 

Table 6-1 Description of tab operations 

To… You can… 

Add a tab Right-click the tab and choose Add on the shortcut menu. 

Remove a tab Right-click the tab and choose Remove on the shortcut menu. 

Rename a tab 

1) Right-click the tab to be renamed. 

2) Choose Rename on the shortcut menu. 
The Rename Page dialog box is displayed, as shown in 
Figure 6-3. 

3) Enter the new name for the tab. 
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Figure 6-3 Rename Page dialog box 

6.3.2  Adding a Pane to a Tab 

You can manage the parameter panes in category by clicking different tabs. 

 

  Note: 

You can use the View tab and the Choose Device option on the standard toolbar to 
open the parameter pane. With this method, you can also operate the peripherals and 
conduct data tracing. 

 

I. Priniciples 

Keep to the following principles when opening the parameter panes: 

 Ensure that the device is configured before opening the parameter window. 
Otherwise, the Probe gives a prompt, indicating that the matched device cannot 
be found, as shown in Figure 6-4. 

 

Figure 6-4 Failing to open the parameter pane 

 If a device to be displayed is of the same type as that selected in the Choose 
Device list, the Probe opens the parameter pane of the device. If several device 
of the same type is available in the Device list, the parameters of the selected 
device are displayed in the pane, as shown in Figure 6-5. 
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Figure 6-5 Parameter window of the selected device 

 If a device to be displayed is not of the same type as the one selected in the 
Choose Device list, the Probe searches in the Device list and displays the 
parameters of the device first found to be matched. 

II. Exceptions 

There are some special windows in which the principles mentioned previously are not 
applicable. 

 In a project, the Map and Indoor Measurement windows are incompatible. The 
Probe gives a prompt if the user tries to open these two windows simultaneously 
in the same project, as shown in Figure 6-6. 

 

Figure 6-6  Incompatible prompt 

 In the windows Event List, Information, Message, only the information of one 
tab can be displayed at a time, as shown in Figure 6-7. 
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Figure 6-7 All UE tab 

Finally, choose File > Save to save the current setting. In this way, the system 
recovers the settings of all the tabs and parameter windows after the system reboot. 

6.4  Configuring a Device 

This section contains the following parts: 

 Adding a Device 
 Deleting a Device 

6.4.1  Adding a Device 

To add a device, perform the following steps: 

1) Choose Configuration > Hardware Config > Manual Config on the main menu. 
The ManualConfig window is displayed, as shown in Figure 6-8. 
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Figure 6-8 ManualConfig window 

2) Click .  

The Device Config dialog box is displayed, as shown in Figure 6-9. 

 

Figure 6-9 Device Config dialog box 

3) Select the type in the Type drop-down list. 
4) Select the device type in the Model drop-down list, such as, the UE type or 

Scanner type. 
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5) Choose the proper baud rate in the Baudrate drop-down list. 
The Probe provides the default bau drate for the device it supports. Select 
115200, 230400, and 4800 for common ports, USB port and GPS respectively. 
For the settings at the device side, refer to Chapter 7  "Connecting the Devices." 

6) Set the port based on the hardware actual connection. For details, refer to device 
manager of the operating system. The port number may not be allocated for the 
device available. 

If the device parameters are not correctly configured, the system returns an error or 
warning prompt, as shown in Figure 6-10. 

 

Figure 6-10 Device configuration information 

6.4.2  Deleting a Device 

When a device in the device list is unnecessary, you can delete it to release the 
system port. 

To delete a device, perform the following steps: 

1) Choose the device to be deleted in the device list. 
The device is highlighted after being selected. 

2) Click  in the ManualConfig window. Alternatively, right-click the device to be 

deleted and choose Delete on the shortcut menu. 
The device list refreshes itself automatically. 

6.5  Importing the Engineering Parameters 

The BTS information can be displayed on the map during the test or log file playback 
only when the engineering parameter list is configured.  

The BTS configuration is automatically saved into a project file for future use. 

6.5.1  Opening the BTS Configuration Window 

I. Importing the WCDMA Engineering Parameters 

To import the WCDMA engineering parameters, choose Configuration > BTS 
Information > WCDMA. 
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The BTS Information (WCDMA) window is displayed, as shown in Figure 6-11. 

 
Figure 6-11 BTS Information (WCDMA) window 

II. Importing the GSM Engineering Parameters 

To import the GSM engineering parameter, choose Configuration > BTS Information 
> GSM. 

The BTS Information (GSM) window is displayed, as shown in Figure 6-12. 

 

Figure 6-12 BTS Information (GSM) window 

6.5.2  Importing the BTS Information 

The Probe supports the BTS information files with either of the following suffixes: 
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 *.csv 
 *.cel 
 *.xls 

To import the BTS information file, perform the following steps: 

1) Click  to open the file dialog box. 
2) Select the BTS information file to be displayed. 

The BTS Information window is displayed, as shown in Figure 6-11. 

Alternatively, you can copy the information directly from the excel files and paste it to 
the BTS file according to columns. 

6.5.3  Editing and Applying the BTS Information 

To edit and apply the BTS information, perform the following steps: 

1) Edit the BTS information on the working panel.  
You can copy or paste the BTS file in the same sheet. Or you can copy or paste 
the data from the Excel into the BTS information window. 

2) Click  to apply the modified BTS information to the map, as shown in Figure 
6-11. 

6.5.4  Displaying the BTS Information on the Map 

To display the BTS information on the map, perform the following steps: 

1) Open the Map window, as shown in Figure 6-13. 
Different cells are distinguished from each other by different colors. The PSC of 
cells are also displayed in the Map window. 
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Figure 6-13 Map window with the BTS information 

2) If other information needs to be displayed, choose Display settings on the Map 
Layers. Alternatively, right-click the Cell and choose Display Settings on the 
shortcut menu, as shown in Figure 6-14. 

 

Figure 6-14 Setting display mode for cell information 

3) In the Display Settings dialog box, select the Site Visible check box, as shown 
in Figure 6-15. 
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Figure 6-15 Display Settings dialog box 

4) Select the site name in the area of Site Label. 
5) Click OK to apply the setting to the Map window. 

 

  Note: 

You can set the cell relation line in the Display Settings dialog box. For details, refer 
to part 9.3.3  "Setting the Cell Relation Line." 

 

6.5.5  Exporting the BTS Information 

To export a BTS information file, click  on the toolbar to save the BTS information 
in the file. 

The BTS information file may be with the format of *.csv or *.cel. 

6.6  Importing a Map 

An imported map shows the drive test track directly and vividly.  

Imported maps contain outdoor maps and indoor maps. An outdoor map shows 
outdoor test tracks while an indoor map displays the indoor test tracks. 

6.6.1  Importing an Outdoor Map 

The outdoor map falls into the following two types: 

 MapInfo digit map 
 Raster map 
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I. Importing and Editing MapInfo Digit Map 

To import the MapInfo digit map, perform the following steps: 

1) Choose View > Map on the main menu of the Probe. Alternatively, double-click 
Map in the View tab. 
The Map window is displayed, as shown in Figure 6-16. 

 

Figure 6-16 Map window 

2) Click . 
3) Choose the map set file with the extension .gst and open it. 

4) Click . 
The Layer Control dialog box is displayed, as shown in Figure 6-17. 



User Manual  
GENEX Probe Wireless Air Interface Testing Software Chapter 6  Managing the Project
 

Huawei Technologies Proprietary 

6-14 

 
Figure 6-17 Layer Control dialog box 

5) Perform some routine operations on the layer, such as adding, deleting, or 
moving the layer. 

6) Click  after editing the map and save the map as a .gst file. 

II. Importing a Raster Map 

A raster map can be used as a background layer. The Probe supports the following 
types of raster maps: 

 .bmp 
 .tif 
 .jpg 
 .gif 
 .png 

To import a raster map, perform the following steps: 

1) Choose View > Map on the main menu of the Probe. Alternatively, double-click 
Map in the View tab. 
The Map window is displayed, as shown in Figure 6-16. 

2) Click  in the Map window. 

3) Double-click the raster map file in the open dialog box. 
The Raster Image dialog box is displayed, as shown in Figure 6-18. 
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Figure 6-18 Raster Image window 

4) Click one point in the map area. 
The Add Control Point dialog box is displayed, as shown in Figure 6-19. 

 

Figure 6-19 Add Control Point dialog box 

5) Specify the label, longitude, latitude, pixel X, and pixel Y. 
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6) Repeat the steps mentioned previously to edit at least three points. 
The more points you edit, the higher the precision is. 

7) Click OK. 
The raster map is displayed as a layer in the Map window. 

8) After editing the raster map, click  to save the map file as a .gst file. 

6.6.2  Importing an Indoor Map 

To import an indoor map, perform the following steps: 

1) Choose View > Indoor Measurement on the main menu. Alternatively, click 
Indoor Measurement in the View tab. 
The Indoor Measurement window is displayed. 

2) Click  on the toolbar. 

The .tif or .bmp File dialog box is displayed.  
3) Choose a file. 
4) Click OK. 

Figure 6-20 shows the Indoor Measurement window after the import of the indoor 
map. 

 

Figure 6-20 Indoor Measurement dialog box 
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6.6.3  Managing Map Layers 

The layers come in the static and the dynamic layers. This part describes only the 
static layer management.  

For details about the dynamic layers, refer to part 9.3.4  "Adding or Deleting a Layer." 

 

  Note: 

Whether the layer is static or dynamic, the layer can be edited in the Layer Control 
dialog box. You can add a dynamic layer on the Map Layers bar. 

 

I. Adding a Static Layer 

To add a static layer, perform the following steps: 

1) Click Add in the Layer Control dialog box. 
2) Choose the required MapInfo Tables in the Add dialog box. 

II. Removing a Static Layer 

To remove a static layer, perform the following steps: 

1) Select the layers to be removed in the area of Layers in the Layer Control dialog 
box. 

2) Click Remove. 

III. Adjusting Layer Sequence 

To adjust the layer sequence, perform the following steps: 

1) Choose the layers whose sequences need adjusting in the Layer Control dialog 
box. 

2) Click Up or Down. 

IV. Setting Layer Properties 

To set layer properties, perform the following steps: 

1) Choose the layers whose properties need revising in the area of Layers in the 
Layer Control dialog box. 

2) Set the layer properties in the area of Properties. 
The properties are as follows: 

 Visible 
 Selectable 
 Automatic Labels 
 Editable 
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  Note: 

For users who familiarize themselves with the MapX, click Display… or Labels… to 
set the layer properties. 

 

6.7  Setting the System 

The system setting involves the setting of the following five modules: 

 Test Plan 
 Log Mask 
 Event 
 Alarm 
 Other 

Except for the Test Plan module, the other four modules provide the default settings. 

You can set different test plans to meet different requirements. Table 6-2 lists 
suggestions for test plan. 

Table 6-2 Suggestions for test plan 

If… Huawei recommends that … 

You use the Probe for the first time and 
would like to be familiar with it 

you go through each subsection to know 
more detailed information. 

You have some knowledge about the 
Probe system configuration, and would 
like to conduct only some routine test 

you go through those modules related to 
the drive test. 

You familize yourself with the Probe 
settings, and would like to know how to 
control the test, control the display data 
or else 

you start with Chapter 9  ”Controlling 
the Test and Playing the Log File Back.” 

 

  Note: 

The hardware must be configured before the system configuration. For details about 
how to connect device hardware, refer to Chapter 7  "Connecting the Devices.” 
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6.7.1  Setting a Test Plan 

For different devices, the Probe offers different test items, and each test item is 
defined by the test properties. You can save a test plan for later use, which ensures 
the consistency and objectiveness of different tests.  

I. Creating a New Test Plan 

At present, the Probe supports the following three types of test devices: 

 UE 
 Scanner 

To create a new test plan, perform the following steps: 

1) Choose Configuration > System Config on the main menu. 
The Test Plan dialog box is displayed, as shown in Figure 6-21. 

 

Figure 6-21 Test Plan dialog box 

2) Choose the device for the test plan from the Device Select drop-down list, as 
shown in Figure 6-22. 

 

Figure 6-22 Device drop-down list 
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3) Click a test item in the TestItem screen. 
The TestItem drop-down list is displayed. 

4) Choose a test item, as shown in Figure 6-23, Figure 6-24, and Figure 6-25. 

 
Figure 6-23 UE test item 

 

Figure 6-24 Anritsu Scanner test item 

 

Figure 6-25 DTI Scanner test item 

 

  Note: 

 In the Probe, several UEs and one Scanner can carry out their test plans at the 
same time. For each UE, several test items can be configured and carried out one 
by one. 

 You can adjust the test sequence to meet different drive test requirements. 
 You can set the properties for each item in the test plan based on the purpose of 

the drive test. For details about the property setting, refer to Chapter 7  
"Connecting the Devices." 

 In case of the manual tests with DTI and Anritsu ML8720B, you need to set the test 
plan before the system receives and analyses the test data. 
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II. Saving a Test Plan 

You can save a configured test plan as a file. 

To save the test plan, perform the following steps: 

1) Click Save or Save as to save the current test plan. 
2) Specify the name and the directory of the current test plan. 

III. Importing a Test Plan 

You can load the test plan information by importing the test plan file.  

To import the test plan, perform the following steps: 

1) Click Open. 
2) Specify the directory of the test plan file and open it. 

6.7.2  Setting the Log Mask 

You can perform the following operations in the LogMask dialog box: 

 Set the LogMask 
 Save the Log file 
 Specify the directory for the Log file 

The LogMask is to: 

 Filter Qualcomm Log data packet  
 Report the specified data packet 

To set the LogMask, perform the following steps: 

1) Click the LogMask icon on the left of the System Config Properties window. 
The LogMask window is displayed, as shown in Figure 6-26. 
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Figure 6-26 LogMask dialog box 

2) Choose the device in the Device drop-down list. 
3) Select the Log to be tested in the Log Item Setting area, as shown in Figure 6-27.  

The UE reports the associated data when certain items are selected. 

 

Figure 6-27 Log Item Setting area 

  Note: 

Figure 6-27 shows the default log item setting. Huawei recommends that you select 
some vital options. If you do not select them, the data file does not contain the 
associated information about the options. 
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4) Click Add to add the custom log masks dynamically. 
After the addition of the log masks, some sub-nodes are displayed under the 
Custom node, as shown in Figure 6-28. 

 

Figure 6-28 Custom logmask 

5) Select the Make Log File check box in the LogMask window. 
The Probe records the drive test data in the log file. If the Make Log File check 
box is not selected, the Probe does not record any drive test data. By default, the 
Probe saves the drive test data as log file. 

6) Select the Limitless or the Limited check box. 
In the former case, the options in the Size Type drop-down list are unavailable. In 
the latter case, you can set the size of the log file. 

 

  Note: 

Two ways are available to limit the size of data file: 
 Control the length of the log file 
 Control the test duration 

The threshold of a record for a single file is about 1.048 x 106. The capacity of hard 
disk is within the range of 100 MB–300 MB (depending on the network environment). 

 

7) Click the unfold button in the filed of Log file directory and choose the specified 
path. 
The Probe generates the name for the log file automatically. The file is named 
after as follows: GENEX_PROBE_Version Number_Auto Date_System Time, for 
example: GENEX_PROBE_1_WCDMA_2004-2-19-15-43-45.gen. You can 
customize the name for the log file. 
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  Note: 

 The sampling rate in the LOG Mask is different from that in Other.  
 LOG Mask is to filter the data based on the requirements. 
 Other is to decide whether or not to set the sampling and sampling frequency. 
 Whether the data is reported or not depends on the LogMask rather than the 

Other dialog box. 

 

6.7.3  Setting the Events 

Table 6-3 lists the default events provided by the Probe. 

Table 6-3 Event list 

Event Type Event Name 

OutgoingCallAttempt 

OutgoingCallAlerting 

OutgoingCallAnswered 

OutgoingCallDisconnected 

Paging Type1 

Paging Type2 

IncomingCallResponsed 

IncomingCallAlerting 

IncomingCallAnswered 

IncomingCallDisconnected 

CMServiceReq 

CMServiceAcpt 

CMServiceRej 

CallDropped 

CallCompleted 

CallSetupFail 

CallState Event 

CallSetupFailing 
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Event Type Event Name 

CallDropping 

CallReSetup 

DataServiceReq 

DataServiceAcpt 

DataServiceRej 

DataServiceSetupFail 

DataServiceDropped 

DataServiceCompleted 

RRCSetupReq 

RRCSetupSuc 

RRCSetupFail 

RRCConnectionRel 

RRCConnectionAbnormalRel 

RRC Event 

RRCState 

RBSetupReq 

RBSetupSuc 

RBSetupFail 

RBReconfigSuc 

RBReconfigFail 

RBRelease 

RB Event 

RBReleaseFail 

SoftHO 

SoftHOFail 

SofterHO 

Soft-SofterHO 

SHO Event 

SofterHO3Cell 
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Event Type Event Name 

SoftHO3Cell 

Event1A 

Event1B 

Event1C 

Event1D 

Event1E 

Event1F 

Event2A 

Event2B 

Event2C 

Event2D 

Event2E 

Event2F 

IntraFreqHHOSuc 

IntraFreqHHOFail 

InterFreqHHOSuc 

HHO Event 

InterFreqHHOFail 

LAUpdateReq 

LAUpdateSuc MM Event 

LAUpdateFail 

AttachSuc 

AttachFail 

PDPActivationReq 

PDPActivationSuc 

PDPActivationFail 

GMM Event 

PDPDeActivation 
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Event Type Event Name 

RAUpdateReq 

RAUpdateSuc 

RAUpdateFail 

CSConnectionHO3Gto2GAttempt 

CSConnectionHO3Gto2GSuc 

CSConnectionHO3Gto2GFail 

CSConnectionHO2Gto3Gattempt 

CSConnectionHO2Gto3GSuc 

CSConnectionHO2Gto3GFail 

PSConnectionHO3Gto2GAttempt 

PSConnectionHO3Gto2GSuc 

PSConnectionHO3Gto2GFail 

3Gto2GCellReselection 

2Gto3GCellReselection 

Event3A 

Event3B 

Event3C 

InterRat Event 

Event3D 

Detach 

CellReselectionConnectedMode 

AuthenticationReq 

AuthenticationRsp 

AuthenticationFail 

SecurityModeReq 

SecurityModeSuc 

Other Event 

SecurityModeFail 
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Event Type Event Name 

AuthenCipherReq 

AuthenCipherSuc 

AuthenCipherFail 

PhChannelRecfgSuc 

PhChannelRecfgFail 

TrChannelRecfgSuc 

TrChannelRecfgFail 

GSMCallAttempt 

GSMCallAttemptFail 

GSMAssignmentSuc 

GSMAssignmentFail 

GSMLateAssignmentSuc 

GSMLateAssignmentFail 

GSMCallAnswered 

GSMCallCompleted 

GSMCallDropped 

GSMOutgoingCallUnReachable 

GSMDisconnected 

GSMOutgoingCallAleritng 

GSMIncomingCallAleritng 

GSM Event 

GSMDataServiceDropped 

 

To configure the events, perform the following steps: 

1) Click the event icon in the left side of the System Config window. 
The Event dialog box is displayed, as shown in Figure 6-29. 
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Figure 6-29 Event dialog box 

2) Choose one event and modify its properties. 

Table 6-4 lists the descriptions of event properties. 

Table 6-4 Descriptions of event properties 

Property Description 

EventName Cannot be modified. 

Shown in EventList 
Decides whether or not to display the events in the event 
list. 

Show in Map Decides whether or not to display the events in the map. 

Icon Sets the symbols for the event display. 

Voice enable 
Decides whether or not to give audible prompt when the 
event occurs. 

Voice Sets the sound file. 

 

6.7.4  Setting the Alarms 

You can set alarms on the alarm setup page. The Probe supports the following four 
alarm items: 
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 UE Disconnection 
 GPS Disconnection 
 SCANNER Disconnection 
 GPS Signal Inadequate 

For each of the previous alarm items, you can choose the visual alarm or audio alarm. 
In case of audio alarm, the sound is user-definable. 

To set the alarms, perform the following steps: 

1) Click the alarm icon on the left of the System Config Properties window. 
The Alarm dialog box is displayed, as shown in Figure 6-30. 

 

Figure 6-30 Alarm dialog box 

2) Choose an alarm in the Alarm Name area. 

: Indicates that the alarm setting takes effect. 

: Indicates that the alarm setting does not take effect. 

3) Choose an alarm type in the Alarm Type area. 
You can either select the Visual Alarm or the Audio Alarm check box 
individually or select both of them at a time. If you select neither of the two boxes, 
the alarms become unavailable. 

4) Click the unfold button in the Sound area to specify the directory of the sound file. 
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6.7.5  Setting Others 

The Others contains: 

 Time 
 DailUp connection 
 Display filter 
 Event playback mode 
 DTI Scanner gain parameter 

 

  Note: 

If the PS service test is not necessary, the dialup connection setting is optional. 

 

I. Setting Time 

Setting the Log Time 

The Probe provides the following two modes to record the time label of each Log 
header in the drive test file: 

 Data-synchronization first 
 UE-Time first 

Figure 6-31 shows the Log Time Setting dialog box. 

 

Figure 6-31 Log Time Setting dialog box 

Table 6-5 lists the setting of the log time. 
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Table 6-5 Setting log time 

If you… The Probe… 

Select the 
Data-synchronization first 
check box 

Chooses the time when the log is loaded on the PC 
as the time for log header. 

Note: 

 The data-synchronization first method 
synchronizes the data of each UE and Scanner 
well. If there are large gap between the PC time 
and UE time, or in case of PC poor performance, 
the time for log header is later than the time 
when the log is actually generated.  

 Thus, the data-synchronization first method is 
not applicable to those signaling packets that 
have high requirements on time precision. 

Select the UE-Time first 
check box 

Chooses the time when the signaling packet is 
generate in the UE as the time for log header, if the 
UE logs are available. 

Chooses the time when the log is loaded on the PC 
as the time for log header, if the other logs are 
available. 

Note: 

The UE-Time first method improves the accurancy 
of time display of the UE logs. The big gap between 
the UE time and PC time leads to the inaccuracy of 
the relative time between UE logs and other logs. 

 

Adjusting the PC Time 

The GPS provides the standard time for the Probe. Namely, the GPS time takes effect 
in the system as long as the GPS is connected to the system. In addition, the GPS 
time can be converted into the local time. 

To adjust the PC time, perform the following steps: 

1) Click Other on the left of the System Config window. 
The Other setup page is displayed, as shown in Figure 6-32. 
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Figure 6-32 Others dialog box 

2) Select the Use GPS time to adjust PC time check box to set the GPS UTC time 
to the PC time, as shown in Figure 6-33. 

3) Select the time in the Time drop-down list. 

 

Figure 6-33 Adjusting the PC time 

Adjusting GPS Position 

To adjust the GPS position, select the Log replay with adjusted GPS position check 
box. 

II. Setting the Dial up Connection 

To set the dial up connection for the PS service, perform the following steps: 

1) Enter the user name in the User field. 
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2) Enter the login password in the Password field. 
3) Enter the call number in the Call Number field, as shown in Figure 6-34. 
4) Enter the time need in the Time Out drop-down list. 
5) Enter the modem initial command in the Modem Init Command field. 

 

Figure 6-34 Dial Up Connection dialog box 

III. Setting the Display Filter 

Before test, you can set the sampling frequency for each device. The sampling 
frequency setting limits the inputs of useless redundant data to a large extent, which 
saves time and system resources.  

By default, the Probe adopts the time sampling for the following two vital parameters: 

 List Search  
 Finger Info for TA 

To set the sampling frequency, perform the following steps: 

1) Choose the sampling device in the Device drop-down list, as shown in Figure 
6-35. 

 

Figure 6-35 Device drop-down list 
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2) Choose the parameters to be filtered. 
3) Choose the filtering type in the Filter Type drop-down list. 

 

  Note: 

The following three sampling modes are available in the setting of the display filter: 
 Sampling by time period: Samples every certain time (ms) 
 Sampling by count: Samples based on the count of data report 
 No sampling: No sampling is conducted on any parameters. Namely, the Probe 

reads the data flowing from the device. 

 

4) Set the sampling frequency value in the Every field. 
 If the sampling mode is by time period, the unit for the sampling value is ms. 
 If the sampling mode is by count, the unit for the sampling value is times. 

IV. Setting the Event Replay Mode 

To set the event replay mode, click the Normal Replay or Re-judge Event box in the 
Event Replay Mode list box, as shown in Figure 6-36. 

 
Figure 6-36 Event Playback Mode list box 

 

  Note: 

 The Normal Replay reads events directly from the log file. 
 The Re-judge Event produces events dynamically. 
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V. Setting DTI Scanner Gain Parameter 

If the antenna gain and cable loss cannot be neutralized, you need to set them 
separately, as shown in Figure 6-37. 

 

Figure 6-37 Parameter dialog box 
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Chapter 7  Connecting the Devices 

7.1  Overview 

The chapter contains the following contents: 

 Setting a UE 
 Setting the GPS Receiver 
 Setting the Anritsu Scanner 
 Setting the DTI Scanner 
 Identifying the Devices 

7.2  Setting a UE 

This section contains the following parts: 

 Setting the UE Connection 
 Setting the Probe 
 Setting the APN for UE 

7.2.1  Setting the UE Connection 

You can connect the testing UE to the PC in the following ways: 

 Through a port 
 Through a USB 
 Through a PCMCIA 

 

  Note: 

 Common UEs are equipped with USB data line, while some UEs have serial port 
cable as well as the USB data line. The serial port cable, however, cannot be 
applied in the actual test due to the limited baud rate. 

 The USB is the main method for connection. The data line is connected to the PC 
through the PCMCIA. 

 

I. Connecting a UE Through a Port 

The port connection mode is applicable to the following UEs: 

 Qualcomm 6200 
 Qualcomm 6250 
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 Qualcomm 6275 

To connect a UE through a port, perform the following steps: 

1) Open a UE. 
2) Connect the UE to a port on the PC through a port data line. 
3) Keep the UE active. 
4) Set the connection mode for the UE port, as listed in Table 7-1. 

II. Connecting a UE Through an USB port 

An USB port serves as an essential mode for the connection of a UE to a PC. At 
present, the USB connection mode is applicable to the following UEs: 

 Qualcomm 6200 
 Qualcomm 6250 
 Qualcomm 6275 
 Huawei U526 
 Huawei U626 
 Huawei U636 

For details about the connection, refer to Table 7-1. 

III. Connecting a UE Through PCMCIA 

The PCMCIA connection mode is only applicable to Huawei E600 and Huawei E620. 
For details about the connection, refer to Operation Guide and User Guide for the 
E600 and the E620. 

Table 7-1 lists the detailed information about UE connection. 

Table 7-1 UE connection 

UE Type Port Connection USB Connection 
PCMCIA 

Connection 

Qualcomm 
6200 

1) Choose Menu > 5 Setting > 
7 Extras > 1 SIO Config > 1 
Port Map > 1 Diag > UART 
to choose the port. 

2) Choose Menu > 5 Setting > 
7 Extras > 1 SIO Config > 1 
Port Map > 2 DS BAUD to 
set the baud rate to 115200.

1) Choose Menu > 5 
Setting > 7 Extras > 1 
SIO Config > 1 Prot 
Map > 1 Diag > USB 
DIAG. 

2) Choose Menu > 5 
Setting > 7 Extras > 1 
SIO Config > 1 Port 
Map > 2 DS BAUD to 
set the baud rate to 
230400. 

Non-supportive 
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UE Type Port Connection USB Connection 
PCMCIA 

Connection 

Qualcomm 
6250 

1) Choose SETTINGS > 
Extras > SIO 
Configuration > Port Map 
> Diag to choose UART1 
(COM1) or UART3 or 
(COM3) based on the port 
number to which the UE is 
connected. 

2) Choose SETTINGS > 
Extras > SIO 
Configuration > DS Baud 
to set the baud rate to 
115200. 

1) Choose SETTINGS > 
Extras > SIO 
Configuration > Port 
Map > Diag to choose 
USB Diag. 

2) Choose SETTINGS > 
Extras > SIO 
Configuration > DS 
Baud to set the baud 
rate to 230400. 

Non-supportive 

Qualcomm 
6275 

1) Choose SETTINGS > 
Extras > SIO 
Configuration > Port Map 
> Diag to choose UART1 
(COM1) or UART3 or 
(COM3) based on the port 
number to which the UE is 
connected. 

2) Choose SETTINGS > 
Extras > SIO 
Configuration > DS Baud 
to set the baud rate to 
115200. 

1) Choose SETTINGS > 
Extras > SIO 
Configuration > Port 
Map > Diag to choose 
the USB Dialog. 

2) Choose SETTINGS > 
Extras > SIO 
Configuration > DS 
Baud to set the baud 
rate to 230400. 

Non-supportive 

Huawei 
U526 

Unavailable No additional setting Non-supportive 

Huawei 
U626 

Unavailable No additional setting Non-supportive 

Huawei 
U636 

Unavailable No additional setting Non-supportive 

Huawei 

E600 
Unavailable No additional setting 

For details, refer 
to Operation 
Guide and User 
Guide for E600. 
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UE Type Port Connection USB Connection 
PCMCIA 

Connection 

Huawei 

E620 
Unavailable No additional setting 

For details, refer 
to Operation 
Guide and User 
Guide for E620. 

Commercial 
UE 

For details, refer to the operation 
guide and user guide. 

For details, refer to the 
operation guide and user 
guide. 

Non-supportive 

 

IV. Installing the Driver 

You need to install the driver correctly on the UE before the first use. 

To install the driver on the Qualcomm 6200, 6250, or 6275, perform the following 
steps: 

1) Connect the Qualcomm UE to the PC through the USB line. 
The system gives a prompt, indicating it is a hardware installation driver. 

2) Choose the installation from the disk. 
3) Choose the qcser2k.inf and qcmdm2k.inf files under the directory of 

\Accessory\Driver\ TM6200 USB Driver 1103. 
4) Update the driver when the UE is in use. 

 

  Note: 

 The update program for TM6250 is under \Accessory 
\Driver\QCUSBCompositeHostDriver2012. 

 The update program for TM6275 is under \Accessory\Driver\ 
QCUSBCompositeHostDriver2032. 

 

To install the driverr on the Huawei U526, U626, U636, E600, or E620, perform the 
following steps: 

1) Connect the Qualcomm UE to the PC through the USB line. 
The system gives a prompt, indicating it is a hardware installation driver. 

2) Choose the installation from the disk. 
3) Choose the associated file under the directory of \Accessory\Driver\Huawei 

626\winXP or Accessory\Driverr\Huawei U626\win2K. 
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  Note: 

 For Huawei U526, the installation directory is \Accessory\Driver\Huawei 526. 
 For Huawei U636, the installation directory is \Accessory\Driver\Huawei 636. 
 For Huawei E600, E620, the installation directories are \Accessory\Driver\E600 

and \Accessory\Driver\E620 respectively. 

 

7.2.2  Setting the Probe 

  Note: 

 Set the UE connected in the Probe system before the test. 
 For detailed information about adding or removing devices in the ManualConfig 

window, refer to section 6.4  "Configuring a Device." 

 

To set the configuration parameters, perform the following steps: 

1) Click  in the ManualConfig window. Alternatively, double-click a device. 

The Device Config dialog box is displayed, as shown in Figure 7-1. 

 

Figure 7-1 Device Config dialog box 

2) Choose UE in the Type drop-down list in the Device Config dialog box. 
The system renames the device automatically. 

3) Set the UE model in the Model drop-down list. 
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4) Choose the baud rate in the Baudrate drop-down list. 
 If the UE is connected with the port on the PC, Huawei recommends setting 

the baud rate to 115200. 
 If the UE is connected with the USB on the PC, Huawei recommends setting 

the baud rate to 230400. 
5) Set the device port. 

 The system searches for the COM port automatically, and adds the new port 
into the Port drop-down list. 

 For the CS service, choose the port that the port Diag corresponds to in the 
Com Port drop-down list. 

 For the PS service, choose the port that the port Modem corresponds to in 
the Modem Port drop-down list, as well as the port that the port Diag corresponds 
to in the Com Port drop-down list. 

6) Click OK. 

 

  Note: 

 When the UE is connected to the PC through a USB, two virtual Com ports are 
displayed for the UE, and named Diag window and Modem window. You can 
distinguish these two windows from each other by checking the port and modem 
configuration. 

 The Diag port must be configured for the test. For the PS service, the Modem port 
must be configured, as well as the Diag port. If the Modem port is not configured, 
the Probe cannot initiate the PS service, let alone record or observe the throughput 
on the application layer. 

 When multiple UEs are connected, several ports are created. Huawei recommends 
connecting the UE and configuration port one by one to avoid any mismatch. 

 

7.2.3  Setting the APN for UE 

You need to set the Access Point Name (APN) for a UE before conducting the PS 
service test. 

I. Setting the APN in the Operating System 

To set the APN in the operating system, perform the following steps: 

1) Open the System Config Properties window. 
2) Unfold the Modem list and choose a modem. 
3) Choose Advanced in the Modem dialog box. 
4) Enter the commands below in the Extra Initialized Command field: 

at+cgdcont=1, "ip", "your APN". 
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5) Click OK. 

II. Setting the APN in the Probe 

To set the APN in the Probe, perform the following steps: 

1) Choose Configuration > System Configuration on the main menu. 
The System Config Properties window is displayed. 

2) Click Other. 
The Other dialog box is displayed, as shown in Figure 7-2. 

 

Figure 7-2 Other dialog box 

3) Enter the command below in the Modem Init Command field:  
at+cgdcont=1, "ip", "your APN". 

4) Click OK. 

You can also set the APN in the test plan. For details, refer to section 8.2  
"Configuring the UE Test Plan." 

III. Setting the APN on the UE 

To set the APN on the Qualcomm 6250 or 6275, perform the following steps: 

1) Choose DATASTATS > Settings > Edit Data Profile on the main menu. 
2) Choose a profile in the Profile list. 
3) Click OK. 
4) Move the mouse to the APN column and click OK. 
5) Enter the APN name and click OK. 
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6) Choose DATASTATS > Settings > Select Active Data > Profile on the main 
menu. 

7) Choose the modified profile in the Profile list. 
8) Click OK to activate. 

To set the APN on the Huawei U526, U626 or U636, perform the following steps: 

1) Choose Menu > Connect > Data account. 
The Profile list is displayed. 

2) Right-click the profile to be edited, and choose Edit on the shortcut menu. 
3) Enter the APN name in the APN Name field and click Save. 
4) Choose Menu > Connect > Modem Setup. 
5) Choose Activation in the USB Modem list. 
6) Choose the edited profile in the Profile list. 
7) Click OK. 

You can set the APN on the Huawei E600 or E620 through the delivery-attached 
programs. 

 

  Note: 

 The three tips metioned previously for the APN setting aim to initialize the UE 
Modem before the data service test. You can achieve the goal by employing any of 
the three methods. 

 Among the three APN setting methods, the APN set in the operating system enjoys 
the highest priority. That is, if the APN are set both in the operating system and in 
the Probe, the former is used to initialize the Modem. This principle is also 
applicable to the maximum downlink and uplink rates.  

 If the APN or the maximum downlink and uplink rates do not work during the test, 
check if they are set previously in the operating system. If the APN or the maximum 
downlink and uplink rates are not set before, initialize the Modem with the latest 
successful setting. 

 

7.3  Setting the GPS Receiver 

This section contains the following parts: 

 Setting the GPS Connection 
 Setting the GPS in the Probe 

7.3.1  Setting the GPS Connection 

To set the GPS connection, perform the following steps: 
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1) Connect the GPS to a PC port through a data line. 
2) Enable the GPS. 
3) Set the GPS protocol with the GPS operating system.  

The NEMA0183 or TAIP protocol is also available. 

7.3.2  Setting the GPS in the Probe 

The setting of GPS in the Probe is similar to that of UE. 

To set the GPS in the Probe, perform the following steps: 

1) Choose GPS in the Type drop-down list, as shown in Figure 7-3. 
2) Choose the GPS model in the Model drop-down list. 
3) Set the baud rate to 4800 in the Baudrate drop-down list. 
4) Click OK. 

 

Figure 7-3 Baudrate drop-down list 

 

  Note: 

The satellite speed differs with the change of application environments. Huawei 
recommends that a period should be spared (usually five minutes) after the GPS 
configuration and before the test. 

 

7.4  Setting the Anritsu Scanner 

This section contains the following parts: 
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 Setting the Anritsu Scanner Connection 
 Setting the Anritsu Scanner in the Probe 

7.4.1  Setting the Anritsu Scanner Connection 

For details about the Anritsu Scanner connection, refer to Anritsu Scanner Operation 
Guide and Anritsu Scanner User Guide. 

7.4.2  Setting the Anritsu Scanner in the Probe 

To set the Anritsu Scanner in the Probe, perform the following steps: 

1) Choose Scanner in the Type drop-down list, as shown in Figure 7-4. 
2) Choose Anritsu ML8720B in the Model drop-down list. 
3) Choose the port number in the Com Port drop-down list. 
4) Set the baud rate to 115200 in the Baudrate list. 
5) Click OK. 

 

Figure 7-4 Model drop-down list 

7.5  Setting the DTI Scanner 

This section contains the following parts: 

 Setting the DTI Scanner Connection 
 Setting the DTI Scanner in the Probe 

7.5.1  Setting the DTI Scanner Connection 

To set the DTI Scanner connection, perform the following steps: 
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1) Connect the DTI Scanner to a PC port through the data line. 
2) Connect the other end of the data line to the battery or power socket. 

After being powered on, the DTI Scanner starts and the light indicator flashes.  

 If the DTI Scanner works well, the light indicator turns green.  
 If the light indicator is yellow for a while or flashes with yellow light, this indicates 

that the power is not sufficient or the DTI Scanner does not work well. 

7.5.2  Setting the DTI Scanner in the Probe 

To set the DTI Scanner in the Probe, perform the following steps: 

1) Choose Scanner in the Type drop-down list, as shown in Figure 7-5. 
2) Choose the type of the current DTI Scanner in the Model drop-down list. 
3) Choose the port No. in the Com Port drop-down list. 
4) Set the baud rate to 115200 in the Baudrate drop-down list. 
5) Click OK. 

 

Figure 7-5 Model drop-down list 

7.6  Identifying the Devices 

The Probe identifies the devices through port scanning. 

To identify the devices, you can choose one or several configured devices and click 

. Alternatively, right-click a configured device and choose Test Port on the shortcut 

menu. 
The system detects the connection status of the port, as shown in Figure 7-6. 
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Figure 7-6 Initializing hardware dialog box 

 

  Note: 

In the event that no devices are selected, the system detects the connection status of 
all ports that connect the devices. 

 

The system returns the test result automatically and updates the port status in the 
Device Config dialog box. 

The status of the devices in the Device Config is displayed by the light indicators, as 
shown in Figure 7-7. 

 Red: Indicates the device is not connected or does not work well. 
 Green: Indicates the device is connected properly. 

 

Figure 7-7 Device indicators 
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Chapter 8  Configuring Test Plan 

8.1  Overview 

This chapter contains the following contents: 

 Configuring the UE Test Plan  
 Configuring the DTI Scanner Test Plan  
 Configuring the Anritsu ML8720B Scanner Test Plan 
 Identifying the Devices 

 

  Caution: 

Set the DTI and SCANNER test plan before conducting the test. In this way, the data 
from DTI or SCANNER can be captured by the Probe. 

 

The test plan supports automatic drive tests. With the simple and easy-to-follow test 
plan, you can conduct a series of drive tests. Table 8-1 lists the brief information about 
the test plan in the Probe. 

Table 8-1 Test plan in the Probe 

For… The Probe … 

UEs and Scanners 

The Probe predefines some test items as follows: 

 UE CS service test 

 UE PS service test 

 CW test 

 Spectrum analysis 

 Pilot test 

 SCH scan 

 RSSI 3.84 M 

 Finger information 

Other devices 
The Probe provides different test items that control test 
process through test properties. 

Same device 
You can set and run the test plans in sequence to excute 
several tasks in batches. 
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For… The Probe … 

CS and PS Service of 
the UE 

You can choose the concurrent test to verify the combined 
service performance. 

Test plan 
The Probe saves it for later searching and sharing with 
other users.  

 

To update the UE type after the completion of the test plan, perform the following 
steps: 

1) Save the test plan. 
2) Modify the UE type. 
3) Import the saved test plan.  

Otherwise, the old test plan is removed. 

8.2  Configuring the UE Test Plan 

This section contains the following parts: 

Voice Call Test 

 Video Phone Test 

PING Test 

 FTP Upload Test 
 FTP Download Test 
 HTTP Test 
 PDP Test 
 PS DialUp Test 

PS HangUp Test 

 Video Streaming Test 

SMS Test 

 AT Control Test 
 Multi-UE Multi-Technology Comparative Test 
 Wait Test  

8.2.1  Voice Call Test 

I. Function Description 

The voice call test verifies the funtions of the automatic test call. 

II. Data Configuration 
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Figure 8-1 shows the data items used in the voice call test. 

 

Figure 8-1 Data items in voice call test 

Table 8-2 describes the data items in the voice call test. 

Table 8-2 Data items in the voice call test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the 
test. 

 True: to enable the test item 

 False: to disable the test item 

Destination Number Indicates the number being called. 

Call Type 

 Continuous call: The call continues if it does not fail, 
drop, or hang up. If the call fails, drops, or hangs up, the 
Probe waits for a call interval to originate another call. 

 Call by call: The call lasts and waits for the 
predetermined calling duration and call interval, and 
repeats for the times defined in call count. 

Vocoder Rate(bps) 
 Indicates the AMR rate. 

 Can be set to 4750, 5150, 5900, 6700, 7400, 7950, 
10200, 12200. 

Setup Time(sec) 
Indicates the maximum time for call setup. If the call cannot 
be setup within the defined period, the call setup fails. 
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Name Description 

Calling Duration(sec) 
 Indicates the duration of one call, from call setup to call 

normal release. 

 The item only applies to the call by call. 

Call Interval(sec) 
Indicates the time between two calls, from the previous call 
disconnection to the beginning of the next call. 

Count Mode 

 Indicates the limitations on the call number. 

 If the value is finite, this indicates that the number of calls 
is limited. The value, however, cannot exceed the value 
of call count. 

 If the value is infinite, this indicates that the number of 
calls is unlimited. 

Call Count 
 Indicates the total number of calls. 

 Applicable to short calls only. 

Exceptional 
Interval(sec) 

Indicates the period between the exceptional end of a call 
and the next call. 

 

 Note: 

Huawei recommends that the PS dialup not be conducted on the Modem of the 
outgoing UE when you conduct the voice call test. 
The UE that is conducting the PS services can serve as an incoming UE for Voice Call 
or Video Phone test, thus realizing the CS and PS concurrent test on the same UE. 
The PS services consist of PING, Ftp Upload, Ftp Download, HTTP, PDP, PS DialUp, 
PS HangUp, Video Streaming, and SMS. 

 

8.2.2  Video Phone Test 

I. Function Description 

The video phone test verifies the funtions of the video call test, which requires that the 
UE and called terminal support this function. 

II. Data Configuration 
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Figure 8-2 shows the data items used in the video phone test. 

 

Figure 8-2 Data items in the video phone test 

The data items in the video phone test have the same implications as that in the voice 
call test. 

8.2.3  PING Test 

I. Function Description 

The PING test verifies the funtions of the automatic PING test. 

II. Data Configuration 
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Figure 8-3 shows the data items used in the PING test. 

 

Figure 8-3 Data items in the PING test 

Table 8-3 describes the data items in the PING test. 

Table 8-3 Data items in the PING test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the 
test. 

 True: to enable the test item 

 False: to disable the test item 

IP Indicates that the destination IP address during PING test. 

Package Size(byte) Indicates that the size of one package. 

Fragment Flag Indicates whether to split a PING packet. 

Test Control Mode 

Indicates the control mode in the PING test. 

Can be set either Test by Count or Test by Time. 

Note: 

By default, the test control mode is Test by Count. 

PING Count Sets the PING counts when Test by Count is selected. 

Test Duration (sec) Sets the PING duration when Test by Time is selected. 

Test Interval (sec) 
Indicates the time between the end of the previous PING 
test and the start of the next one. 
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8.2.4  FTP Upload Test 

I. Function Description 

The FTP upload test verifies the functions of the automatic upload test. 

II. Data Configuration 

Figure 8-4 shows data items used in the FTP upload test. 

 

Figure 8-4 Data items in the FTP upload test 

Table 8-4 describes the data items in the FTP upload test. 

Table 8-4 Data items in the FTP upload test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the 
test. 

 True: to enable the test item 

 False: to disable the test item 

Port 
Indicates that the port of the server. By default, the port 
number is considered to be 21. 

User Indicates the username if required during FTP upload. 

Password Indicates the passwords if required during FTP upload. 
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Name Description 

Remote File 

Indicates the name and path of destination file on the server. 
It should be in the following format: 

[ftp://]+IP address+”/”+file name (including the file path) 

For example, 10.0.0.1/upload/test.dat. 

Local file 
Indicates the absolute path for the source file, for example, 
c:\test.dat. 

Test Interval (sec) Indicates the interval between two uploads. 

FTP Count Indicates the total number of the FTP tests. 

Disconnection Mode 

Indicates whether or not to disconnect the data connection. 

The following three options are available: 

 Keep connected 
After the loading of the target file, do not conduct the 
PDP deactivation while maintaining the RRC connection. 
After the Interval Time period, initiate the next FTP 
Download. 

 Disconnected by time 
Condut the PDP deactivation every Valid FTP Duration. If 
the download is not complete in the preset period, the 
result shows Timeout and the download is considered a 
failure. Initiate the PDP deactivation after the Valid FTP 
Duration. 

 Discnnected after transfer completed 
Initiate the PDP deactivation after the loading of a file. 

Note: 

By default, the disconnection mode is keep connected. 

Valid FTP Duration 
(sec) 

Indicates the duration between the activation and 
disconnection of the data link, if the Disconnected by time 
is selected in the Disconnection Mode. 

Note: 

The value is 60 seconds by default. 
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Name Description 

Traffic class 

Indicates the type of the traffic. These types are as follows: 

 Background class 

 Conversational class 

 Interactive class 

 Streaming class 

 Subscribed class 

UL Max Rate(kbps) Indicates the maximum uplink rate. 

DL Max Rate(kbps) Indicates the maximum downlink rate. 

UL Guaranteed 
Rate(kbps) 

Indicates the guaranteed uplink rate. 

DL Guaranteed 
Rate(kbps) 

Indicates the guranteed downlink rate. 

 

  Note: 

Before the FTP upload test, ensure that you have the authority to upload the files to 
the specified directory. 

 

8.2.5  FTP Download Test 

I. Function Description 

The FTP download test verifies the funtions of the automatic FTP download test. 

II. Data Configuration 

Figure 8-5 shows the data items used in the FTP download test. 
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Figure 8-5 Data items in the FTP download test 

Table 8-5 describes the data items in the FTP download test. 

Table 8-5 Data items in the FTP download test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the test. 

 True: to enable the test item 

 False: to disable the test item 

Port 
Indicates that the port of the server. By default, the port number 
is considered to be 21. 

User Indicates the username if required during FTP download. 

Password Indicates the passwords if required during FTP download. 

Remote File 

Indicates the name and path of destination file on the server. It 
should be in the following format: 

[ftp://]+IP address+”/”+file name (including the file path) 

For example, 10.0.0.1/download/test.dat. 

Write Local File 

Indicates whether or not to save the downloaded file on the local 
PC. 

Note: 

The default value is False. 
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Name Description 

Local File 
Indicates the path to save a file when Write Local File is True. 
For example, c:\test.dat. 

MultiTask Count 

Indicates the number of files to be downloaded. 

Note: 

The defalt value is 1. 

Test Interval 
(sec) 

Indicates the interval between two downloads. 

FTP Count Indicates the total number of the FTP tests. 

Disconnection 
Mode 

Indicates whether or not to disconnect the data connection. 

The following three options are available: 

 Keep connected 
The Probe does not conduct the PDP context deactivation 
after the target files are loaded completely. After the interval 
time, the Probe initiates the next FTP download. 

 Disconnected by time 
The Probe performs the PDP context deactivation based on 
the period. The period for the PDP context deactivation is 
represented by the Valid FTP Duration parameter. If the 
target files are not loaded completely within the predefined 
time, the loading result shows timeout. The Probe considers 
this loading as failure and initiates another PDP context 
deactivation in the next loading. 

 Discnnected after transfer completed 
The Probe performs the PDP context deactivation each time 
when the file load is complete. 

Valid FTP 
Duration(sec) 

Indicates the duration between the activation and disconnection 
of the data link, if Disconnection Mode is Disconnected by 
time. 

Note: 

The default value is 60 seconds. 
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Name Description 

Traffic Class 

Indicates the types of the traffic. These types are as follows: 

 Background class 

 Conversational class 

 Interactive class 

 Streaming class 

 Subscribed class 

UL Max 
Rate(kbps) 

Indicates the maximum uplink rate. 

DL Max 
Rate(kbps) 

Indicates the maximum downlink rate. 

UL Guaranteed 
Rate(kbps) 

Indicates the guaranteed uplink rate. 

DL Guaranteed 
Rate(kbps) 

Indicates the guranteed downlink rate. 

 

  Note: 

 As a vital indicator in the HSDPA test, the download rate is affected by air interface, 
the size of TCP/IP reception window, and the MTU. Use the multi-thread download 
tools to stabilize the HSDPA rate. 

 If the traffic class is background class or interactive class, the guaranted rate 
becomes unnecessary. 

 

8.2.6  HTTP Test 

I. Function Description 

The HTTP test is to verify the automatic HTTP test functionality. 

II. Data Configuration 

Figure 8-6 shows the data items used in the HTTP test. 
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Figure 8-6 Data items in the HTTP test 

Table 8-6 describes the data items in the HTTP test. 

Table 8-6 Data items in the HTTP test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the 
test. 

 True: to enable the test item 

 False: to disable the test item 

URL Indicates the destination HTTP address of the server. 

Port 
Indicates the HTTP serving port. By default, it is considered 
to be 80. 

Control Mode 

Indicates the HTTP control mode.  

 Test by time: Test based on time. 

 Test by state: Test based on the RRC state. 

Test Interval(sec) 

Indicates the time between two HTTP tests. 

Note: 

This parameter takes effect when Control Mode is Test by 
time. 



User Manual  
GENEX Probe Wireless Air Interface Testing Software Chapter 8  Configuring Test Plan
 

Huawei Technologies Proprietary 

8-14 

Name Description 

HTTP Count 

Indicates the number of HTTP tests. 

Note: 

This parameter takes effect when Control Mode is Test by 
time. 

 

8.2.7  PDP Test 

I. Function Description 

The PDP test verifies the functions of the automatic and continuous PDP context 
activation and PDP context deactivation test. 

II. Data Configuration 

Figure 8-7 shows the data items used in the PDP test. 

 

Figure 8-7 Data items in the PDP test 

Table 8-7 describes the data items in the PDP test. 

Table 8-7 Data items in the PDP test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the test. 

 True: to enable the test item 

 False: to disable the test item 
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Name Description 

PDP Type Indicates the types of PDP, such as IP or PPP. 

PDP APN Indicates the access point name. 

Traffic Class 

Indicates the types of the traffic. These types are as follows: 

 Background class 

 Conversational class 

 Interactive class 

 Streaming class 

 Subscribed class 

UL Max 
Rate(kbps) 

Indicates the maximum uplink rate. 

DL Max 
Rate(kbps) 

Indicates the maximum downlink rate. 

UL Guaranteed 
Rate(kbps) 

Indicates the guaranteed uplink rate. 

DL Guaranteed 
Rate(kbps) 

Indicates the guranteed downlink rate. 

Auto Dialup 

Indicates whether or not to set the automatic dialup. 

This parameter can be set to False (No dialup) or True (Dialup).

Note: 

False is by default. 

Reserved 
Duration(sec) 

The duration refers to the period from the PDP context activation 
to the PDP context deactivation. 

Deactivation 
Duration (sec) 

Indicates the period from the previous PDP context deactivation 
to the next PDP context activation. 

PDP Count 
Indicates the number of PDP context activation and PDP context 
deactivation pair tests. 
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  Note: 

 If False is selected in the Auto Dialup, the connections on the signaling plane are 
set up. The signaling includes RRC signaling, PDP context activation request, PDP 
context activation reception message. The service plane, however, is not 
established. In such a situation, the PING service is not being connected. 

 If True is selected in the Need Dialup, the connections on both signaling and 
service planes are established. That is, the PC <-> UE <-> CN channel is setup for 
dialup connection and providing services. 

 

8.2.8  PS DialUp Test 

I. Function Description 

The PS dialup test is performed to establish a PS service connection. Set up an item 
for PS dialup test before a PS service test, such as FTP Upload, FTP Download, PING, 
and HTTP. Otherwise, the Probe attempts the PS dialup and modifies the APN and 
QoS using the AT command or using the latest successful setting for the APN and 
QoS. 

II. Data Configuration 

Figure 8-8 shows the data items used in the PS dialup test. 

 

Figure 8-8 Data items in the PS dialup test 

Table 8-8 describes the data items in the PS dialup test. 
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Table 8-8 Data items in the PS dialup test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the test. 

 True: to enable the test item 

 False: to disable the test item 

PDP APN Indicates the access point name. 

PDP Type Indicates the types of PDP, such as IP or PPP. 

Traffic Class 

Indicates the types of the traffic. These types are as follows: 

 Background class 

 Conversational class 

 Interactive class 

 Streaming class 

 Subscribed class 

UL Max 
Rate(kbps) 

Indicates the maximum uplink rate. 

DL Max 
Rate(kbps) 

Indicates the maximum downlink rate. 

UL Guaranteed 
Rate(kbps) 

Indicates the guaranteed uplink rate. 

DL Guaranteed 
Rate(kbps) 

Indicates the guranteed downlink rate. 

 

  Note: 

You do not have to set the uplink and downlink guranteed rates for the background 
class and interactive class. According the protocols, the guranteed rate is irrelevant in 
the background class and interactive class. Some UEs do not support setting the 
guranteed rate for the background class and interactive class, which may lead to the 
failure of PS dialup test. 

 

8.2.9  PS HangUp Test 

I. Function Description 

The PS hangup test is to accomplish the automatic PS hangup test. 
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II. Data Configuration 

Figure 8-9 shows the data items used in the PS hangup test. 

 

Figure 8-9 Data items in the PS handup test 

Table 8-9 describes the data items in the PS hangup test. 

Table 8-9 Data items in the PS hangup test 

Name Description 

Enable 

Indicates whether or not to disconnect the current data connection. 

 True: to disconnect the data connection 

 False: to keep the data connection 

 

8.2.10  Video Streaming Test 

I. Function Description 

The video streaming test is to accomplish the automatic and continuing video 
streaming test. 

II. Data Configuration 

Figure 8-10 shows the data items used in the video streaming test. 
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Figure 8-10 Data items in the video streaming test 

Table 8-10 describes the data items in the video streaming test. 

Table 8-10 Data items in the video streaming test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the test. 

 True: to enable the test item 

 False: to disable the test item 

URL 
Indicates the URL of the destination file, for example, 
tsp://192.168.34.154/athens/wuhuan.rm. 

Test Count Indicates the count of the cyclic play. 

 

8.2.11  SMS Test 

I. Function Description 

The SMS test is to accomplish the automatic and continuing SMS test. 

II. Data Configuration 

Figure 8-11 shows the data items used in the SMS test. 
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Figure 8-11 Data items in the SMS test 

Table 8-11 describes the data items in the SMS test. 

Table 8-11 Data items in the SMS test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the 
test. 

 True: To enable the test item. 

 False: To disable the test item. 

Service Center Address Indicates the number of short message service center. 

Message 
Indicates the short message content. The string can be 
entered. 

Destination Number Indicates the destination address of the short message. 

Test Count Indicates the total sending count. 

Test Interval(sec) Indicates the duration between two messages. 

 

8.2.12  AT Control Test 

I. Function Description 

The AT control test is to verify the AT control test functionality on a commercial UE. 
Connect the commercial UE to the Probe to carry out this test. 
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II. Data Configuration 

Figure 8-12 shows the data items used in the AT control test. 

 

Figure 8-12 Data items in the AT control test 

The AT control provides the following functions: 

 Import and export the AT commands 
 Group the AT commands 
 Move the AT commands up and down 

Figure 8-13 shows the AT Command Edit dialog box. 
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Figure 8-13 AT Command Edit dialog box 

 

  Note: 

Test the AT commands on each UE before the AT control test, because the AT 
commands and their formats supported by different vendor differ in many ways. 

 

8.2.13  Multi-UE Multi-Technology Comparative Test 

I. Function Description 

The Probe can conduct the voice call, Video or Phone test on several UEs in different 
networks. 

The multi-UE multi-technology comparative test is to accomplish the comparative test 
on different UEs in the different networks. 
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II. Procedures 

  Note: 

Before the multi-UE multi-technology comparative test, ensure that the UEs are 
connected to the current device. 

 

To conduct the multi-UE multi-technology comparative test, perform the following 
steps: 

1) Select the Multi-UE concurrently performing box in the System Config 
Properties window, and choose the service type that is concurrently performed, 
as shown in Figure 8-14. 
The Multi-UE Concurrently Setting dialog box is displayed, as shown in Figure 
8-15. 

 

Figure 8-14 Multi-UE test check box 
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Figure 8-15 Multi-UE concurrently test Setting dialog box 

2) Add or delete the UEs for the comparative tests and set the destination call 
number for each UE. 

3) Click OK. 
The destination call number is displayed in the TestItem area, as shown in Figure 
8-16. 

 

Figure 8-16 Comparative test succeeded 
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  Note: 

The other configuration items are invalid in the test plan. The Up, Down, Delete, or 
Save button becomes unavailable. 

 

III. Data Configuration 

Figure 8-17 shows the data items in the multi-UE multi-technology comparative test. 
You can edit the call number or the call setup time in the data configuration window. 

 

Figure 8-17 Data items in the multi-UE multi-technology comparative test 

8.2.14  Wait Test 

I. Function Description 

The Wait test is used to set the time interval between two test items. 

II. Data Configuration 

Figure 8-18 shows the data items in the wait test. 
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Figure 8-18 Data items in the wait test 

Table 8-12 lists the descriptions of the data items in the wait test. 

Table 8-12 Descriptions of the data items in the wait test 

Name Description 

Enable 

Indicates whether or not to enable this test item. 

 True: to enable the test item 

 False: to disable the test item 

Wait 
Duration(sec) 

Sets the waiting period. 

Note: 

The default value is five seconds.. 

 

8.3  Configuring the DTI Scanner Test Plan 

This section contains the following parts: 

 TopN Pilot Scan Test 
 Spectrum Analysis  

CW Test 

 Pilot Scan Test  
 SCH Scan Test  
 RSSI Test  
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8.3.1  TopN Pilot Scan Test 

I. Function Description 

The TopN pilot scan test is to scan the TopN pilot. 

II. Data Configuration 

Figure 8-19 shows the data items in the TopN pilot scan test. 

 

Figure 8-19 Data items in the TopN pilot scan test 

Table 8-13 describes the data items in the TopN pilot scan test. 

Table 8-13 Data items in the TopN pilot scan test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the 
test. 

 True: to enable the test item 

 False: to disable the test item 

Channel 

Indicates the scanned ARFCN. 

Note: 

At most, the six ARFCNs can be scanned simultaneously. 
These ARFCNs should be separated from each other by 
commas. 

PilotNumber (N) 
 Indicates the TopN strongest pilot. 

 Ranges from 1 to 32. 
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Name Description 

ChipWindowSize Adopts the default value. 

PNThreshold(dB) Adopts the default value. 

ScanRate(ms) Adopts the default value. 

Measure Ec/Io 

Indicates whether or not to measure the Ec/Io. 

 True: Enable the Ec/Io measurement. 

 False: Disable the Ec/Io measurement. 

Measure Time 
Offset 

Indicates whether or not to measure the time offset. 

 True: Enable the time offset measurement. 

 False: Disable the time offset measurement. 

Measure Aggregate 
Ec/Io 

Indicates whether or not to measure the aggregate Ec/Io. 

 True: Enable the aggregate Ec/Io measurement. 

 False: Disable the aggregate Ec/Io measurement. 

Measure Delay 
Spread 

Indicates whether or not to measure the transmission delay.

 True: Enable the transmission delay measurement. 

 False: Disable the transmission delay measurement. 

Measure Eps/Io 

Indicates whether or not to measure the Eps/Io. 

 True: Enable the Eps/Io measurement. 

 False: Disable the Eps/Io measurement. 

Measure Ess/Io 

Indicates whether or not to measure the Ess/Io. 

 True: Enable the Ess/Io measurement. 

 False: Disable the Ess/Io measurement. 

Measure Rake 
Finger Count 

Indicates whether or not to measure the rake finger count. 

 True: Enable the rake finger count measurement. 

 False: Disable the rake finger count measurement. 

Measure SIR 

Indicates whether or not to measure the SIR. 

 True: Enable the SIR measurement. 

 False: Disable the SIR measurement. 
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8.3.2  Spectrum Analysis 

I. Function Description 

The spectrum analysis is to accomplish the spectrum analysis test. 

II. Data Configuration 

Figure 8-20 shows the data items in the spectrum analysis. 

 

Figure 8-20 Data items in the spectrum analysis 

Table 8-14 describes the data items in the spectrum analysis. 

Table 8-14 Data items in the spectrum analysis 

Name Description 

Enable 

Indicates whether or not to enable this test item after the test. 

 True: to enable the test item 

 False: to disable the test item 

Center 
frequency (MHz) 

Indicates the frequency of the center. 

Span (MHz) Indicates the scan spectrum (MHz). The 45 MHz is at most. 

RBW (KHz) Adopts the default value. 

Sweep count Adopts the default value. 

ScanRate (ms) Adopts the default value. 

 

8.3.3  CW Test 

I. Function Description 

The CW test is to accomplish the propagation model correction and cell planning. The 
CW test is describes from the following perspectives: 
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 Principle 
The DTI Scanner receives the signals from the CW transmitter, and obtains the 
CW test conclusion through the post processing based on the geographic 
information. 

 Sampling 
The DTI Scanner conducts 50 samplings in the distance of 40 wave lengths. In 
this way, the sampling data can reflect the wireless environment. 

 Calculation 
Vmax = (40 x λ)/(50 x T) 

Where: 

 Vmax: indicates the maximum vehicle speed. 
 Λ: Indicates the CW wave length. 

Take the 2100 MHz for example. The wave length is 0.1428 m. If the DTI sampling rate 
is 6 ms, the maximum vehicle speed is 72 km/h. 

II. Data Configuration 

Figure 8-21 shows the data items in the CW test. 

 
Figure 8-21 Data items in the CW test 

Table 8-15 describes the data items in the CW test. 

Table 8-15 Data items in the CW test 

Name Description 

Enable 

Indicates whether or not to enable a test item after the test. 

 True: to enable a test item 

 False: to disable a test item 

Channel 
Indicates the frequency of CW signal, namely five times of the 
frequency. 

ScanRate 

Indicates the sampling frequency and comes in: 

 2 ms 

 4 ms 

 6 ms 
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Name Description 

MaxSpeed 
Indicates the maximum vehicle speed, which can be set 
automatically based on the different sampling frequency. 

 

  Note: 

If the CW test is conducted, the other test items should be disabled. 

 

8.3.4  Pilot Scan Test 

I. Function Description 

The pilot scan test is to accomplish the scan of the specified pilot. 

II. Data Configuration 

Figure 8-22 shows the data items in the pilot scan test. 

 

Figure 8-22 Data items in the pilot scan test 

Table 8-16 describes the data items in the pilot scan test. 

Table 8-16 Data items in the pilot scan test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the test. 

 True: to enable the test item 

 False: to disable the test item 
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Name Description 

Channel 

Indicates the specified pilot to be scanned, including the ARFCN and 
scrambling code. 

Note: 

 You can add several ARFCNs separated by commas.  

 During the multi-frequency scan, six ARFCNs can be added at most.

 There are no limitations on the number of the scrambling codes 
under each ARFCN. 

 

  Note: 

The configurations of the other test items are similar to that in the TopN pilot scan test. 

 

8.3.5  SCH Scan Test 

I. Function Description 

The SCH scan test is to obtain the Ec/Io of one SCH timeslot (2560 chips). 

II. Data Configuration 

Figure 8-23 shows the data items in the SCH scan test. 

 

Figure 8-23 Data items in the SCH scan test 

Table 8-17 describes the data items in the SCH scan test. 

Table 8-17 Data items in the SCH scan test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the test. 

 True: to enable the test item 

 False: to disable the test item 
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Name Description 

Channel 

Indicates the scan ARFCN. 

Note: 

At most six ARFCNs can be scanned simultaneously. These 
ARFCHs are separated by commas. 

ScanRate (ms) Adopts the default value. 

 

8.3.6  RSSI Test 

I. Function Description 

The RSSI test is to check the coverage distribution of the carrier strength. 

II. Data Configuration 

Figure 8-24 shows the data items in the RSSI test. 

 

Figure 8-24 Data items in the RSSI test 

Table 8-18 describes the data items in the RSSI test. 

Table 8-18 Data items in the RSSI test 

Name Description 

Enable 

Indicates whether or not to enable this test item after the test. 

 True: to enable the test item 

 False: to disable the test item 

Channel 

Indicates the scan ARFCN. 

Note: 

At most six ARFCNs can be scanned simultaneously. These ARFCHs 
are separated by commas. 
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  Note: 

 The DTI Scanner supports testing several items spontaneously. Ensure that True 
should be selected in the Enable field for at least one test item during the 
configuration of DTI Scanner plan. 

 Since the items are tested in different periods, the frequency of data sampling is 
affected when several items are tested spontaneously. Huawei recommends that 
True is selected in the Enable field only for one test item in each test. 

 

8.4  Configuring the Anritsu ML8720B Scanner Test Plan 

For the Anritsu ML8720B Scanner, the Probe provides the following two test plans:  

 Unspecified Base Station Measurement 
 Specified Base Station Measurement 

8.4.1  Unspecified Base Station Measurement 

I. Unspecified 

The Unspecified is to set the common properties of the unspecified base station 
measurement. 

Table 8-19 describes the data items in the unspecified base station measurement. 

Table 8-19 Data items in the unspecified base station measurement 

Name Description 

Enable Sets whether this test item is valid or not. 

Calibrate user (dB) 

Sets the value for user correction, which is used for the 
compensation of cable loss. 

Note: 

By default, the user correct is 0 dB. 

Reference input Adopts the default value: False. 

Adjust antenna 
Sets the adjustment in antenna gain. 

Adopts the default value: Disable. 

 

II. Conditions 

The Conditions lists the conditions for the test items in the unspecified base station 
measurement. 
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Table 8-20 describes the test items in the unspecified base station measurement. 

Table 8-20 Test items in the unspecified base station measurement 

Name Description 

Measurement 
duration (sec) 

Indicates the measurement period. The recommended value 
is 0.5 s. 

Fingers at ANT1 

Indicates the maximum number of fingers available at ANT1. 
Ranges from 1 to 6. 

Note: 

The recommended value is 6. 

Fingers at ANT2 

Indicates the maximum number of fingers available at ANT2. 
Ranges from 1 to 6. 

Note: 

If the Scanner does not install the diversity antenna, the value 
is 0. 

Diversity 

Indicates whether or not to be diversified. 

Note: 

Set to OFF if no hardware for diversity is available. 

All methods 

Indicates that the data processing method that applies to 
RSCP, Ec/No, SIR. 

Note: 

Set to Average in the All Method field. 

RSCP method Indicates the method for processing RSCP data. 

Ec/No method Indicates the method for processing Ec/No data. 

SIR method Indicates the method for processing SIR data. 

RAKE threshold 
(dB) 

Indicates the RAKE threshold. 

Ranges from 0 dB to 20 dB. 

Note: 

The effective range should be within the best finger and (the 
best finger – rake threshold). 
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Name Description 

Selection level 
(dB) 

Indicates the selection level. 

Ranges from 0 dB to 20 dB. 

Note: 

The finger whose value exceeds (receiver noise + selection 
level) can be accepted. 

Carrier frequency 
(MHz) 

Indicates the frequency of the carrier. 

Ranges from 2110.0 MHz to 2200.0 MHz. 

 

III. CH Limits 

The CH limits are settings for such items as primary scrambling code, secondary 
scrambling code, or cell. 

Table 8-21 describes the data items in the CH limits. 

Table 8-21 Data items in the CH limits 

Name Description 

Group number start 
Indicates the starting number of a primary scrambling code 
group. 

Group number end 
Indicates the ending number of a primary scrambling code 
group. 

Cell number start Indicates the start number for cells. 

Cell number end Indicates the end number for cells. 

Min.secondary SC Indicates the minimum of the secondary scrambling codes. 

Max.secondary SC Indicates the maximum of the secondary scrambling codes. 

Searching method Indicates the search mode: P-CPICH or SCH. 

Measurement 
channels 

Indicates the number of measurement channels. 

Ranges from 1 to 32. 

Specified channels 
Indicates the number of the specified channel. When 
Specified Channels is enabled, Measurement Channels 
does not take effect. 
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IV. CH Code 

The CH code refers to the channel code, which includes primary scrambling code, 
secondary scrambling code, and channel code, as shown in Figure 8-25. 

 
Figure 8-25 MeasureChannel dialog box 

8.4.2  Specified Base Station Measurement 

I. Specified 

The Specified sets the common properties of the data items in the specified base 
station measurement. 

Table 8-22 lists the specified data items in the specified base station measurement. 

Table 8-22 Specified data items in the specified base station measurement 

Name Description 

Enable Sets whether this test item is valid or not. 

Calibrate user (dB) 

Sets the value for user correction, which compensates the 
cable loss. 

Note: 

By default, the user correct is 0 dB. 

Reference input Adopts the default value: false. 

Adjust antenna  
Sets the adjustment in antenna gain. 

Adopts the default value: Disable. 
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II. Conditions 

The Conditions lists the conditions for the test items in the specified base station 
measurement. These conditions are as follows: 

 Measurement period 
 Rake reception threshold 

Table 8-23 describes the conditions in the specified base station measurement. 

Table 8-23 Conditions in the specified base station measurement 

Name Description 

Measurement 
duration (sec) 

Indicates the measurement period. The 0.5s is 
recommended. 

Figures at ANT1 

Indicates the maximum number of fingers available at ANT1. 
Ranges from 1 to 6. 

Note: 

Huawei recommends adopting the maximum value. 

Fingers at At ANT2 

Indicates the maximum number of fingers available at ANT2. 
Ranges from 1 to 6. 

Note: 

If the Scanner is not installed with the diversity antenna, the 
value here is 0. 

Diversity 

Indicates whether or not to conduct diversify. 

Note: 

Set to OFF if no hardware for diversity is available. 

All methods 

Indicates that the data processing method that applies to 
RSCP, Ec/No, SIR. 

Note: 

The recommended value is Average in the All Method field.

RSCP method Indicates the processing method for RSCP data. 

Ec/No method Indicates the processing method for Ec/No data. 

SIR method Indicates the processing method for SIR data. 
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Name Description 

RAKE threshold 
(dB) 

 Indicates the RAKE threshold. 

 Ranges from 0 dB to 20 dB. 

Note: 

The effective range should be within the best finger and (the 
best finger – rake threshold). 

Selection level (dB) 

 Indicates the selection level. 

 Ranges from 0 dB to 20 dB. 

Note: 

The finger whose value exceeds (receiver noise + selection 
level) can be accepted. 

Carrier frequency 
(MHz) 

 Indicates the frequency of the carrier. 

 Ranges from 2110.0 MHz to 2200.0 MHz. 

 

III. CH Code 

The CH code refers to the channel code, which includes the setting of primary 
scrambling code, secondary scrambling code, or channel code, as shown in Figure 
8-26. 

 
Figure 8-26 MeasureChannel dialog box 
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Chapter 9  Controlling the Test and Playing the Log 

File Back 

9.1  Overview 

This chapter provides guidance for test operation and log file playback. 

This chapter contains the following contents: 

 Conducting a Test 
 Outdoor Test  
 Indoor Test 
 Real-Time Test 
 Controlling the Log File Playback  

9.2  Conducting a Test 

This section contains the following parts: 

 Starting a Test 
 Stopping a Test 
 Pausing or Resuming Recording 
 Pausing or Resuming Screen 
 Capturing a Window 
 Capturing a Page 
 Marking a Map 

9.2.1  Starting a Test 

Table 9-1 lists the three ways to start a test. 

Table 9-1 Three ways to start a test 

Method Operation 

From the menu Choose Test > Start Test. 

From the Navigator Click the start test icon on the navigator. 

From the toolbar Click the start test icon on the toolbar. 
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  Note: 

 Before the test, the Probe gives a prompt, indicating whether to save the log file or 
not. At that time, the system starts the test, but does not save the log file. 

 If the Make Log File is not selected in the LogMask, the system does not save the 
Log file. 

 

9.2.2  Stopping a Test 

Table 9-2 lists the three ways to stop a test. 

Table 9-2 Three ways to stop a test 

Method Operation 

From the menu Choose Test > Stop Test. 

From the Navigator Click the stop test icon on the navigator. 

From the toolbar Click the stop test icon on the toolbar. 

 

You can stop or cancel some test plans by selecting some options on the shortcut 
menu in the Information window. For details, refer to part 9.5.2  "Shortcut Menu for 
Information Window." 

9.2.3  Pausing or Resuming Recording 

I. Reason 

The reason for the record pause is that the drive test car may reside on a place for a 
long time due to traffic jam or red lights. When you need to record the data, you can 
choose to resume recording. 

II. Method 

Table 9-3 lists the three ways to pause or resume recording. 

Table 9-3 Three ways to pause or resume recording 

Method Operation 

From the menu Choose Test > Record Pause/Resume. 

From the navigator Click the record pause/resume icon on the navigator. 

From the toolbar Click the record pause/resume icon on the toolbar. 
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9.2.4  Pausing or Resuming Screen Scrolling 

I. Reason 

When data exceptions occur, you need to check the parameters in the window. The 
screen pause function enables you to locate the problem. After that, you can resume 
the screen scrolling. 

II. Method 

Table 9-4 lists the three ways to pause or resume the screen scrolling. 

Table 9-4 Three ways to pause or resume screen scrolling 

Method Operation 

From the menu Choose Test > Screen Pause/Resume. 

From the navigator Click the screen pause/resume icon on the navigator. 

From the toolbar Click the screen pause/resume icon on the toolbar. 

 

9.2.5  Capturing a Window 

I. Reason 

You may need to capture a window to meet the specified requirements during the drive 
test. The captured window is saved in a .bmp file under \Capture. 

II. Method 

Table 9-5 lists the three ways to capture a window. 

Table 9-5 Three ways to capture a window 

Method Operation 

From the menu Choose Test > Capture Window. 

From the Navigator Click the capture window icon on the navigator. 

From the toolbar Click the capture window icon on the toolbar. 
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9.2.6  Capturing a Page 

I. Reason 

You may need to capture a certain page in the current window to meet the specified 
requirements during the drive test. The captured page is saved in a .bmp file under 
\Capture. 

II. Method 

You can capture a page by choosing Test > Capture Page. 

9.2.7  Marking a Map 

You can use some shortcut keys to mark a map during the drive test. 

To mark the map, you can choose Configuration > Map Mark. 

Table 9-6 lists the shortcut keys to mark a map. 

Table 9-6 Shortcut keys to mark a map 

Shortcut Key Function 

F7 
Marks the current position on the map and allows the users to 
enter text marks. 

F8 Marks the current position on the map without text marks. 

 

  Note: 

The Mark can be modified if you double-click it in the idle mode. The MAP Mark 
cannot be modified during the real-time test or log file playback. 

 

9.3  Outdoor Test 

This section contains the following parts: 

 Importing Area Geographic Information 
 Loading the Engineering Parameters 
 Setting the Cell Relation Line 
 Adding or Deleting a Layer 
 Defining a Layer Legend  
 Searching for a Cell 
 Adjusting the GPS Position 
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9.3.1  Importing Area Geographic Information 

The area geographic information are as follows: 

 Digit map 
 Raster map 

To import the digit map, perform the following steps: 

1) Click Open Geoset file on the toolbar in the MAP window. 
2) Choose a file with the suffix gst. 
3) Click OK. 

For details, refer to part 6.6.1  “Importing an Outdoor Map.” 

To import the raster map, perform the following steps: 

1) Click Raster Image on the toolbar in the MAP window. 
2) Choose the file format of a raster map (including .bmp, .jpg, .tif, .gif, and .png). 
3) Click OK. 

For details, refer to part 6.6.1  “Importing an Outdoor Map.” 

 

  Note: 

For details about the import of area graphic information, refer to part 6.6.1  "Importing 
an Outdoor Map." 

 

9.3.2  Loading the Engineering Parameters 

For details about the load of the engineering parameter, refer to section 6.5  
"Importing the Engineering Parameter." 

9.3.3  Setting the Cell Relation Line 

To set the cell relation line, perform the following steps: 

1) Right-click Cell on the toolbar of the Map layers. 
2) Choose Display Settings… on the shortcut menu. 

The Display Settings dialog box is displayed, as shown in Figure 9-1. 
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Figure 9-1 Display Settings dialog box 

3) Modify the properties of the relation line in the area of Active set display in the 
Display Settings dialog box. 

 

  Note: 

The area of Site Label is used to set the display mode of cell labels. For details, refer 
to part 6.5.4  "Displaying the BTS Information on the Map." 
By default, there are relation lines available between the UE and the cells. You can 
clear the Cell check box in the May Layers pane to remove the line. 

 

9.3.4  Adding or Deleting a Layer 

The following lists the two methods to modify a layer: 

 Click the Layer Control icon on the toolbar, and manage the layer in the Layer 
Control dialog box. For details, refer to part 6.6.3  "Managing Map Layers." 

 Click the icons on the toolbar in the Map Layers pane to manage a layer. 

 

  Note: 

The second method is applicable only to the dynamic layers. The dynamic spot display 
during the drive test or test playback relies on the correct settings in the dynamic layer. 

 

To add a map layer, perform the following steps: 
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1) Click Add Layer on the toolbar. Or choose Add Layer…on the shortcut menu. 
The Add Layer dialog box is displayed, as shown in Figure 9-2. 

 

Figure 9-2 Adding Layer dialog box 

2) Set the parameters such as device, layer type, and visibility in the Add Layer 
dialog box. 

3) Click OK. 

 

  Note: 

If you select Parameter in the Layer Type area, you need to define map legends in 
the Parameter Layer dialog box. 

 

9.3.5  Defining a Layer Legend 

To define a layer legend, perform the following steps: 

1) Right-click a layer. 
2) Choose Edit Layer to edit the layer, as shown in Figure 9-3. 
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Figure 9-3 Parameter Layer dialog box 

3) Click Add, Edit, Remove or Auto Setup to modify the layer legend  
4) Click Start Test. 

 

  Note: 

 The Offset in the Parameter Layer dialog box refers to the offset between layer 
position and actual GPS track. 

 The Channel Selection is available when the multi-frequency parameter layer is 
added by the DTI Scanner. 

 

9.3.6  Searching for a Cell 

To search for a cell, perform the following steps: 

1) Click Cell Search on the toolbar. 
2) Enter the cell information in the displayed dialog box. 
3) Click Search. 

The cell search result is displayed in the displayed dialog box. 
4) Double-click a cell in the dialog box. 

The selected cell is centered in the Map window. 
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  Note: 

The cell search is optional. 

 

9.3.7  Adjusting the GPS Position 

The low GPS precision results in the offset between the actual position and the display 
position shown in the Map window. You can adjust the GPS position to make up for the 
insufficient GPS precision. The Probe supports the following GPS adjustments: 

 Dynamic adjustment 
 Static adjustment 

I. Adjusting the GPS Position Dynamically 

To adjust the GPS position dynamically, perform the following steps: 

1) Right-click in the Map window. 
2) Choose Enable Adjustment on the shortcut menu. 

The GPS adjustment is enabled. 
3) Choose Offset Angle on the shortcut menu. 

The Offset Angle dialog box is displayed. 
4) Enter the offset angle and click OK.  

The Probe adjusts the track automatically on the map based on the offset angle. 

To adjust the GPS position statically, you can choose Log playback with adjust GPS 
position in the Others tab in the System Config window. For details, refer to part 
6.7.5  "Setting Others." 

 

  Note: 

The static GPS adjustment is valid only during the playback. 

 

II. Adjusting the GPS Position Statically 

To adjust the GPS position statically during the playback, perform the following steps: 

1) Right-click in the Map window. 
2) Choose Enable Adjustment on the shortcut menu. 

The static GPS adjustment is enabled. 

3) Click  on the map toolbar. 

4) Drag the data sampling points to the required positions. 
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The Probe moves along the modified track during the log file playback. 

9.4  Indoor Test 

This section contains the following parts: 

 Walking Test 
 Vertical Test 

Two types of indoor tests are available:  

 Walking test: collects the signals horizontally distributed in the building. 
 Vertical test: collects the signals vertically distributed in the building. 

To enable the walking test, perform the following steps: 

1) Right-click in the Indoor Measurement window. 
2) Choose Walking Test > Automatic/Manual on the shortcut menu. 

To enable the vertical test, perform the following steps: 

1) Right-click in the Indoor Measurement window. 
2) Choose Vertical Test on the shortcut menu. 

9.4.1  Walking Test 

The walking test comes in: 

 Automatic walking test 
 Manual walking test 

I. Automatic Walking Test 

To conduct the automatic walking test, perform the following steps: 

1) Right-click in the Indoor Measurement window. 
2) Choose Automatic Walking Test on the shortcut menu. 
3) Use the localizer to mark the testing route. 
4) Click Start Test. 
5) Precede the test following the predefined test route. 
6) When the marked point is reached, press the space key to show the gathered test 

data on the map. 
7) Repeat the previous steps to gather the test data. 
8) End the test. 

II. Manual Walking Test 

To conduct the manual walking test, perform the following steps: 

1) Right-click in the Indoor Measurement window. 
2) Choose Manual Walking Test on the shortcut menu. 
3) Click Start Test. 
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4) Use the localizer to mark the current position on the map during the test. 
The system utilizes the geographic binning method to display the test data 
between the marked points on the map. 

5) End the test. 

9.4.2  Vertical Test 

To conduct the vertical test, perform the following steps: 

1) Double-click the Indoor Measurement window. 
2) Choose Vertical Test on the shortcut menu. 
3) Click Start Test. 
4) Switch the stories by clicking the direction button ↓ or ↑, as shown in Figure 9-4. 

The system displays the test data based on the different stories. 

 

Figure 9-4 Direction button 

5) End the test. 

9.5  Real-Time Test Statistics 

The Information Statistics window helps you to monitor the current test items. The 
window automatically creates pages for each connected test device to display the test 
plan and the test completion information of the device. 

This section contains the following parts: 

 Managing the Information Statistic Window 
 Shortcut Menu for Information Window 

9.5.1  Managing the Information Statistic Window 

To operate on the information statistic window, perform the following steps: 

1) Click the Information node in the navigator. 
2) Click the equipment tab in the Information window, as shown in Figure 9-5. 

The progress status bar about each test item is displayed. 
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Figure 9-5 UE1 tab 

3) View the statistic information to trace the test item. 

9.5.2  Shortcut Menu for Information Window 

I. Shortcut Menu of Test Item 

The eqipment page is used to trace each test item or stop an item when required. 

To stop a test item, perform the following steps: 

1) Right-click a test item in the equipment page. 
2) Choose Stop Test Item on the shortcut menu, as shown in Figure 9-6. 
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Figure 9-6 Stop Test Item option 

9.6  Controlling the Log File Playback 

This section contains the following parts: 

 Opening and Previewing a Log File 
 Controlling the Playback Speed and Direction 
 Locating a Log File 
 Co-Activating the Window 

The Probe system supports the playback of the Log files, which enables you to 
observe the network performance or to locate the network troubles. 

To control the log file playback, perform the following steps: 

1) Choose Open Logfile on the Logfile menu. 
2) Control the log file playback through the menu or the icons on the logfile toolbar, 

as shown in Figure 9-7. 

 

Figure 9-7 Logfile toolbar 

Table 9-7 describes the icons on the logfile toolbar. 
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Table 9-7 Icons on the logfile toolbar 

Button Function 

 To open a log file. 

 To start a playback. 

 To pause a playback. 

 To stop a playback. 

 

To control the playback direction. 

By default, the system conducts the forward playback. If you press 
the button once, the system plays back forward. If you press button 
twice, the system plays back backward. 

 
To locate a log file. 

For details, refer to part 9.6.3  "Locating a Log File." 

 

  Note: 

You can operate the progress bar or time input box to locate the playback position. 

 

9.6.1  Opening and Previewing a Log File 

To open and preview a log file, perform the following steps: 

1) Click Open Logfile on the Log toolbar. 
2) Double-click a log file to open it.  
3) View the log file information in the Log Files tab of the Information window, as 

shown in Figure 9-8. 
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Figure 9-8 Preview information in the Log File tab 

4) Double-click the node of the parameters to be observed on the navigator to open 
the associated windows. 

5) Click Play Logfile to play the log file back. 
6) Control the playback of the log file playback through the buttons on the Logfile 

toolbar. 
7) End the playback of the log file. 

9.6.2  Controlling the Playback Speed and Direction 

I. Controlling the Playback Speed 

The system supports up to 8 times and down to 1/8 times playback speed adjustment. 

The following two ways are available for speed control: 

 Choose Speed Up or Speed Down on the Logfile menu. 
 Select a speed in Speed Control drop-down list, as shown in Figure 9-9. 

 

Figure 9-9 Speed Control drop-down list 

II. Controlling the Playback Direction 

The following two ways are available to control the direction: 
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 Click the forward/backward button  on the Logfile toolbar. 

 Choose Play Backward on the Logfile menu. 

9.6.3  Locating a Log File 

To locate a log file, perform the following steps: 

1) Click the unfold button to choose a log file, as shown in Figure 9-10. 

 

Figure 9-10 Opening Logfile dialog box 

2) Select Preview Event: Preview visible Event for Event List. 
3) Click OK. 

4) Choose Logfile > Locate. Alternatively, click  (Location button) on the 

Logfile toolbar. 
The Find Event window is displayed, as shown in Figure 9-11. 



User Manual  
GENEX Probe Wireless Air Interface Testing Software

Chapter 9  
Controlling the Test and Playing the Log File Back

 

Huawei Technologies Proprietary 

9-17 

 

Figure 9-11 Find Event dialog box 

5) Choose the devices and events to be located. 
6) Click Search. 

The Probe displays the event and its occurring time in the list. 
7) Choose an event and click Find. 

The system locates the event automatically and displays it in the chart. 

9.6.4  Co-Activating the Window 

The Probe provides the window co-activation function. 

Table 9-8 lists the results during the co-activation. 

Table 9-8 Results during the co-activation 

If… Then… 

The system is in playback or 
real-time measurement status 

The system co-activates only with the data in the 
current window. 
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If… Then… 

The system is in the status of 
playback pause 

The system displays a data segment round the 
triggering data extracted from the playback file 
during the co-activation. At the same time, the 
triggering data is highlighted in the associated 
windows. 

The data information at the current time is 
displayed in the parameter window. 

 

Through either of the following ways, you can trigger the window co-activation: 

 Click a message in the Message window. 
 Click an event in the Event List window. 
 Click the signal indicator in the Map window or Indoor Measurement window. 
 Press and hold the Ctrl button, and click in the Chart window. 
 Select an event in the Found Event dialog box, and click Find, as shown in 

Figure 9-11.  
This operation is valid only in the log file playback mode. 
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Chapter 10  Continuous Wave Test 

10.1  Overview 

During the network planning, it is necessary to calibrate the radio propagation models. 
This job is usually done by gathering continuous wave (CW) test data and entering 
them to model calibration application.  

The Probe has the following advantages for the CW test: 

 The Probe provides the built-in CW test.  
 The Probe utilizes the discrete GPS information to deal with the mismatch 

between GPS information and signal strength information.  
 The Probe conducts the geographic binning and bad data filtering during the CW 

test, and exports the data for the network planning. 

This chapter describes the following: 

 Adding and Identifying the DTI Scanner 
 Configuring the Test Plan 
 Adding a Test Window 
 Starting a Test 
 Exporting and Processing the CW Data 

10.2  Adding and Identifying the DTI Scanner 

Before the test, you need to correctly identify the DTI Scanner.  

To configure the hardware manually in the Probe and set the DTI Scanner parameters, 
perform the following steps: 

1) Choose Configuration > Hardware Config > Manual Config on the main menu. 
The ManualConfig window is displayed. 

2) Click  to add a device, as shown in Figure 10-1. 
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Figure 10-1 Adding a device 

3) Double-click the device in the Device List in the ManualConfig window. 
The Device Config window is displayed. 

4) Choose Scanner in the Type drop-down list and set the model of DTI Scanner in 
the Model drop-down list, as shown in Figure 10-2. 

 

Figure 10-2 Model drop-down list 
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5) Click  to identify the device in the ManualConfig window. 

After the device identification, Success, Failed or Error is displayed in the device 
status. 

10.3  Configuring the Test Plan 

After the configuration of the DTI Scanner, you also need to configure the CW 
measurement plan based on the device configuration. 

To configure the test plan, perform the following steps: 

1) Choose Configuration > System Config on the main menu.  
The Test Plan dialog box is displayed. 

2) Click the test item row and choose the items for the DTI Scanner, as shown in 
Figure 10-3. 

 

Figure 10-3 Selecting test items 

3) Enable the CW measurement. Namely, ensure that TRUE is selected in the 
Enable area, while the False is selected for other test items, as shown in Figure 
10-4. 
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Figure 10-4 Enabling the CW test items 

4) Click OK. 

10.4  Adding a Test Window 

The test window comes in the following two types: 

 Map: observes the historical track of the CW data. 
 CW Test: views the current CW test data. 

Figure 10-5 shows the CW test window and map window. 

 

Figure 10-5 CW Test and Map option 
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To add a layer for the CW test, perform the following steps: 

1) Click  in the Map window. 

The Add Layer dialog box is displayed. 
2) Choose a Scanner in the Device drop-down list. 
3) Choose Parameter in the Layer Type drop-down list. 
4) Select the Visible check box, as shown in Figure 10-6. 

 

Figure 10-6 Add Layer dialog box 

5) Click OK. 
The Parameter Layer dialog box is displayed, as shown in Figure 10-7. 

 

Figure 10-7 Parameter Layer 

6) Choose CW RSSI in the Parameter drop-down list. 
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7) Select the Channel Selection check box and choose a frequence in the 
drop-down list. 

8) Click OK. 

10.5  Starting a Test 

After the configuration and preparation, click Start Test in the Probe to start a test. 

10.6  Exporting and Processing the CW Data 

For details about the export and process of the CW data, refer to part 11.3.7   
"Exporting the DTI Test Data." 



User Manual  
GENEX Probe Wireless Air Interface Testing Software Chapter 11  File Exporting Funtion
 

Huawei Technologies Proprietary 

11-1 

Chapter 11  File Exporting Funtion 

11.1  Overview 

The Probe provides powerful data processing function, as listed in Table 11-1. 

Table 11-1 Powerful data processing 

If… You can… 

The data is exported in the .bin format Conduct the focused analysis. 

The data is exported in the .txt format 
View the formats and contents of some 
packages. 

The data is exported in the .QXDM 
format 

Give the feedbacks to the Qualcomm for 
troubleshooting. 

the data about UE measure is exported 
in the .xls format, 

Analyze the UE measure by using the 
networking planning application. 

The data about UE message is exported 
in the .xls format 

Analyze the UE message based on 
signaling. 

The data about the Anritsu or DTI is 
exported in the .xls format 

Calibrate the propagation model by using 
the planning application software. 

Note: 

The CW test filters the data based on the 
geographic binning and bad spots 
removal. 

The two drive test files that meet the 
requirements are combined 

Give a synthesis analysis on the network 
troubles. 

 

11.2  Exporting the Data 

To export the data, perform the following steps: 

1) Choose Logfile Menu > Export Data on the main menu.  
The Log Wizard – Step One dialog box is displayed, as shown in Figure 11-1. 
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Figure 11-1 Log Wizard – Step One dialog box 

2) Choose the data export mode in the Export As drop-down list, as shown in 
Figure 11-2. 
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Figure 11-2 Export As drop-down list 

3) Select the source file and the destination file. 
The properties of the source file are displayed in the File Information and 
Packet Selection areas, as shown in Figure 11-3. 
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Figure 11-3 Selecting the source file and the destination file 

4) Select the device type in the Device field in the Log Selection area, as shown in 
Figure 11-4. 
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Figure 11-4 Selecting the log 

5) Select the log type in the Log Mask field in the Log Selection area. 
For the DTI device, you can select some log files for export. 

 

  Note: 

 The settings in the Log Selection area are applicable only to the UE and the DTI 
Scanner. 

 When Bin or Merge is chosen as the export format, the GPS-In-DTI selects the 
GPS information contained in the selected DTI Scanner in the Log Selection area, 
and exports the information either individually or with Scanner. 

 

6) Click Start. 
The system starts to export the data. 
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  Note: 

If the Explore the Exporting Destination Folder check box is selected, this indicates 
the target folder is open at the conclusion of the export (Default). Otherwise, the target 
folder will not be open at the conclusion of the export. 

 

7) View the progress bar to check the export status. 
8) Click Stop. 

The system stops exporting the data. 
9) Click Reset. 

The system returns to the first step of data export, as shown in Figure 11-5. 

 

Figure 11-5 Exporting the data 

11.3  Exporting the Data with Different Formats 

This section contains the following parts: 

 Exporting the Data into .bin Format 
 Exporting the Data into .txt Format 
 Exporting the Data into .QXDM Format 
 Exporting the UE Measure into .xls Format 
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 Exporting the UE Message into .xls Format 
 Exporting the ANRITSU Data into .xls Format 
 Exporting the DTI Test Data 

11.3.1  Exporting the Data into .bin Format 

If you select Bin in the Export Format drop-down list, the Probe exports the data 
based on the original binary format. 

By default, one file is exported at a time. Multiple files can be exported at the same 
time only when Bin and Multi-file are selected in the Export Format drop-down list. 

The equipment information of the first log file serves for reference.  

The exported files have the following features: 

 Mapping with the source files one by one 
 Being saved in the same target folder 
 Being directly opened and played back 

11.3.2  Exporting the Data into .txt Format 

If you select Text in the Export Format drop-down list, the Probe exports the data into 
the .txt format to facilitate the data view and query. 

11.3.3  Exporting the Data into .QXDM Format 

If you select QXDM in the Export Format drop-down list, the Probe exports the data 
into the .QXDM format. In this way, you can use the QCAT (an application from the 
Qualcomm) to locate the network trouble. 

11.3.4  Exporting the UE Measure into .xls Format 

If you select Excel (UE Measure) in the Export Format drop-down list, the Probe 
exports the UE measure data. You can conduct the analysis by employing the network 
planning software. 

11.3.5  Exporting the UE Message into .xls Format 

If you select Excel (UE Message) in the Export Format drop-down list, the Probe 
exports the UE message. The Probe exports the signaling on the layer 2 and layer 3 to 
facilitate the call analysis and trouble locating. 

11.3.6  Exporting the ANRITSU Data into .xls Format 

If you select Excel (ANRITSU) in the Export Format drop-down list, the Probe 
exports the Anritsu data in .xls format. 
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11.3.7  Exporting the DTI Test Data 

Before exporting the DTI test data, you need to select the DTI test data to be exported 
in the LogMask. For details, refer to section 11.2  "Exporting the Data." 

To export the DTI test data, perform the following steps: 

1) Choose Excel (DTI) in the Export As drop-down list. 
2) Click Export Format. 

The Setting dialog box is displayed, as shown in Figure 11-6. 

 

Figure 11-6 Setting dialog box 

3) Conduct the following settings, as listed in Table 11-2. 
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Table 11-2 DTI export format setting 

In the area of… You can… 

In the Column area 

1) Choose one item in the DTI Data Type drop-down 
list. 

2) Customize the column header in the Column 
Header. 

Note: 

Alternatively, double-click one item in the column header 
to edit it. 
The icons on the toolbar are used for deleting and sorting 
operations. 

In the Format area 

1) Choose the format with which the GPS information is 
exported in the GPS drop-down list. 

2) Choose the time and date for export in the Date and 
Time drop-down list. 

3) Choose the frequency unit in the Frequency list. 

In the CW Data area 

1) Select the Binning by distance check box. 

2) Enter the length based on the geographic binning. 
The default value is 6 m. 

3) Select the Threshold lower limit check box. 

4) Enter the custom upper and lower limits. 

Note: 

The 6 m is the length of the 40 waves in the 2000 MHz 
frequency. 

In the File Size area 

You can designate limits on the file size by: 

 Sizes 

 Records 

Note: 

 If the data in one file exceeds the file size, the data 
flows into another file. 

 If the GPS information is necessary option is selected, 
the Probe filters the data without the GPS information. 
Otherwise, all the data is exported. 
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  Note: 

 The feature of geographic binning is added in the DTI data export in the Probe V1.2. 
You can export the data for propagation model calibration. 

 The geographic binning in the Probe adopts new algorithm and avoids the 
expiration of CW data and geographic information error. 

 

11.4  Merging Log Files 

To merge log files, perform the following steps: 

1) Choose Logfile > Export Data. 
2) Click Merge in the Log Export dialog box. 

The procedure for merging log files is similar to that in exporting log data, with 
difference in file selection and export page layout. 

3) Click Add or Delete to add or delete the log file and set the size of the generated 
log file. 
For details, refer to section 11.2  "Exporting the Data." 

 

  Note: 

The Probe merges several log files based on the original binary format. The 
information about the device in the first log file serves as a reference and the data is 
merged by device port. The saved file can be opened and played back. 
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Chapter 12  FAQ 

12.1  Why Cannot the Probe Be Enabled in a Normal Way? 

I. Problem Description 

The Probe cannot be enabled normally. The system gives a prompt, saying "Lock 
Error: Verify Lock Fail." 

II. Solution 

To solve the problem, perform the following steps: 

1) Check if the hard dongle is connected. Connect the hard dongle if it is 
unavailable. 

2) Check if the driver for the hard dongle is installed. Install the hard dongle driver 
before putting the hard dongle in use. 

3) Check if the device ports work well. 
4) If the reason why the Probe cannot be enabled normally is due to other hard 

dongles have been installed, you need to uninstall the Sentinal Driver in the 
Control Panel, and re-install the GENEX Share. 

12.2  Why Cannot the Probe Detect a UE? 

I. Problem Description 

The UE cannot be detected after the port configuration. 

II. Solution 

If the system gives the Error prompt, it indicates the port is being occupied. In such a 
situation, ensure that other applications that may utilize the port have been closed. 
Re-connect to the UE. If the problem still exists, reboot the PC. 

If the system gives a failure prompt, do as listed in Table 12-1. 
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Table 12-1 Solution to detecting UE 

If… You can… 

The UE is connected to 
the PC through the USB 
port 

1) Right-click My Computer. 

2) Choose the Manager > Device Manager. 

3) Check if the UE port is under the COM and LPT 
tree and if it works well. 
If the UE port does not work well, re-install the 
driver. 

4) Check the UE setting. 
Ensure that the UE is connected through the USB 
port. 

5) Ensure the serial port in the Hardware Config list is 
consistent with that in the device manager. 

6) Set the BaudRate to 230400. 

The UE is connected to 
the PC through a port 

1) Check if the COM port works well. 

2) Choose Menu > 5 Setting > 7 Extras > 1 SIO 
Config > 1 Port Map > 1 Diag to set to UART. 

3) Choose the SIO Config > 2 DS BAUD. 

4) Set the baud rate to 115200. 

5) Ensure that the settings of Port and BaudRate in 
the Probe are same as that in the UE. 

Note: 

Only the Qualcomm 6200 and 6250 can be connected 
to the serial port. 

 

12.3  Why Cannot the Probe Detect the GPS? 

I. Problem Description 

The Probe cannot detect the GPS. 

II. Solution 

To solve this problem, perform the following steps: 

1) Check if the settings of port No and BaudRate in the Hardware Config are 
correct. 

2) Check if the interface protocol is NEMA through the GPS match application 
software. 
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12.4  Why Cannot the Probe Detect the Anritsu Scanner 

I. Problem Description 

The Probe cannot detect the Anritsu Scanner. 

II. Solution 

To solve the problem, perform the following steps: 

1) Check if the settings of port No and BaudRate in the Hardware Config are 
correct. 

2) Check the settings of Anritsu Scanner Interface. 
3) Choose Direct as the protocol. 
4) Set the baud rate same to that in the Probe. 
5) Use the default value in other options (8 digit bit, 1 stop bit, no parity check). 

12.5  Why Cannot the Mouse Be Controlled After PC 
Switched On or Reboot? 

I. Problem Description 

The mouse cannot be controlled after the PC switched on or reboot. 

II. Reason 

The problem is caused by the fact that you reboot or switch on the PC when the GPS 
or DTI is connected. 

III. Solution 

Extract the GPS or DTI data line, reboot the PC and re-insert the data line. 

12.6  Why Cannot Some Messages Be Reported? 

I. Problem 

In the event that the UE is in the GSM mode, conduct the test. You find that no data is 
received. The adjustment in the UE and the interface rate cannot solve the problem. 

II. Reason 

Some message packages cannot be reported because of the heavy amounts of 
WCDMA messages. 

III. Solution 

To solve the problem, you can close the logmask of some message packets that need 
no observation. 
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  Note: 

 The engineers can open the required Logmask before test. 
 For details, refer to part 6.7.2  "Setting the Log Mask." 

 

12.7  Why Cannot the Map Window Be Open? 

I. Problem Description 

The Map window or the Indoor Measurement window cannot be opened. The system 
gives a prompt, saying "Please install the maps plug-in". 

II. Solultion 

To solve the problem, you can re-install the GENEX Share component package. 

12.8  Why Cannot the Base Station Window Be Open? 

I. Problem Description 

The Base Station window cannot be opened. The system gives a prompt, saying 
"Please install the Office plug-in." 

II. Solution 

To solve the problem, you can re-install the GENEX Share component package. 

12.9  Why Cannot the Chart Window Be Open? 

I. Problem Description 

The Chart window cannot be opened. The system gives a prompt, saying "Please 
install the Teechart plug-in." 

II. Solution 

To solve the problem, you can re-install the GENEX Share component package. 

12.10  Why Cannot the Probe be Installed or Uninstalled? 

I. Problem Description 

If the local PC is equipped with the Probe 1.2, Probe 1.3 or the ealier ones, you may 
not succeed in installing the Probe 1.3, though receiveing the installation success 
information. 
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II. Solution 

The different kits used in the intallation packets lead to the incompatibility between the 
new and old Probe versions. In such a situation, Huawei recommends that you 
uninstall the old Probe version first, and then install the new one. 

If the old Probe version cannot be uninstalled in the Control Panel, to remove the old 
Probe version, perform the following steps: 

1) Click Start.  
2) Click Run and enter regedit to open the registry. 
3) Remove the HKEY_LOCAL_MACHINE\SOFTWARE\Huawei GENEX\Probe 1.2 

(Or Probe 1.3) in the navigation tree. 
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Appendix A  Common Parameters and Shortcuts 

A.1  Common Parameters 

The section describes the following: 

 System Performance 
 DTI Scanner Parameter 

A.1.1  System Performance 

The system performance is listed from the following perspectives: 

 Support 8 UEs and Scanners at the same time.  
 Run 8 hours continuously without faults 
 Support WCDMA/GSM air interface test 
 Test data during UE powered on or off 
 Scan multiple UARFCN by the DTI Scanner at the same time 
 Connect to the UE and Scanner automatically without human involvement 

A.1.2  DTI Scanner Parameter 

I. Antenna 

Table A-1 lists the antenna parameters. 

Table A-1 Antenna parameter 

Max. 
power 

Antenna 
type 

Coax type Gain Freq (MHz) 
Dimension 

(Antenna stub)

150 
Watts 

Low profile LMR195 4 dB 2100 1 ¾ inches 

 

II. Cable 

Table A-2 lists the cable parameters. 

Table A-2 Cable parameter 

Loss Length Total loss 

17.5 dB/100 in 12 in 2.1 dB 
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III. Battery 

Charge: 4 hours 

Discharge: 3 hours 

Table A-3 lists the battery parameters. 

Table A-3 Battery 

Item Reference value 

Weight 2.5 lb 

Size 1.25” h x 5.25” w x 6.5” d  

Nominal capacity 19.2 Ah 

Battery type Sealed Lead 

Fuse 3 A Fast Blow, Type 3 AG 

Input power connector 5.5 × 2.5mm coaxial plug 

Output power connector DB15 Female 

 

IV. Scanner 

Table A-4 lists the Scanner parameters. 

Table A-4 Scanner 

Receiver Sensitivity −19dB for Ec/Io CPICH (pilot channel)  

−116dBm for Ec (RSCP) 

Scan rate for CW test 4 ms 

Sampling Precision ±1 dBm 

 

A.2  System Shortcut Keys 

The Probe provides some system shortcut keys to facilitate your operation. 

Table A-5 lists the shortcut keys for system operation. 

Table A-5 Shortcut keys for system operation 

Operation Shortcut keys 

File New Project Ctrl + N 
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Operation Shortcut keys 

Open Project Ctrl + O 

Save Project Ctrl + S 

Close Project Ctrl + C 

Open Logfile Ctrl + L 

Close Logfile Ctrl + H 

Play F6 

Stop Shift + F6 

Speed up Ctrl + Num + 

Log File 

Speed down Ctrl + Num - 

Start Test F5 

Stop Test Shift + F5 Test 

Record Pause PAUSE 

Add Ctrl + Insert 

Delete Ctrl + Delete 

Edit Ctrl + Return 

Auto Config Ctrl + Shift + A 

Hardware 
Configuration 

Manual Config Ctrl + M 

Enable adjustment Ctrl + J 

Exit adjustment Ctrl + Q Map 

Offset Angle Ctrl + Alt + A 

Switch to Test Control Panel Alt + 1 

Switch to View Panel Alt + 2 

Switch to Property Panel Alt + 3 

Swith to Previous Page Ctrl + Alt + I 

Swith to Next Page Alt + Z 

Interface 

Message Page Swithover Ctrl + Alt + U 
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Operation Shortcut keys 

Capture Window Ctrl + P 

Capture Page Ctrl + Alt + P 

Screen Pause/Resume F10 
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Appendix B  Acronyms and Abbreviations 

A 

AMR Adaptive MultiRate 

APN Access Point Name 

APP Application 

  

B 

BLER Block Error Rate 

  

C 

CW Continuous Wave 

  

N  

NAS Non-access Stratum 

  

R 

RRC Radio Resource Control 

RSCP Received Signal Code Power 

RSSI Received Signal Strength Indication 

  

S 

SCH Synchronized Channel 

  

T 

TPC Transmit Power control 
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U 

UARFCN UMTS Absolute Radio Frequency Channel Number 
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Index 

A 
about this manual, 1-7 

C 
conducting test 

conducting CW test, 10-1 

conducting indoor test, 9-10 

conducting outdoor test, 9-4 

overview, 9-1 

configuring Anritsu scanner test plan, 8-34 

configuring device 

adding device, 6-6 

deleting device, 6-8 

configuring DTI scanner test plan 

CW test, 8-29 

pilot scan test, 8-31 

RSSI test, 8-33 

SCH scan test, 8-32 

spectrum analysis, 8-29 

topn pilot scan test, 8-27 

configuring UE test plan 

comparative test, 8-22 

control test, 8-20 

ftp download test, 8-9 

ftp upload test, 8-7 

http test, 8-12 

PDP test, 8-14 

ping test, 8-5 

PS dialup test, 8-16 

PS hangup test, 8-17 

SMS test, 8-19 

video phone test, 8-4 

video streaming test, 8-18 

voice call test, 8-2 

wait test, 8-25 

connecting decvice 

identifying devices, 7-11 

setting anritsu scanner, 7-9 

setting DTI scanner, 7-10 

setting GPS receiver, 7-8 

setting UE, 7-1 

controlling log file playback, 9-13 

D 
different exported data formats, 11-6 

E 
exporting data, 11-1 

I 
importing map 

importing indoor map, 6-16 

importing outdoor map, 6-12 

managing map layers, 6-17 

installing probe 

copyright protection, 4-8 

hardware equipment, 4-2 

hardware requirements, 4-1 

installing GENEX shared, 4-7 

installing probe, 2-1, 4-2 

M 
main feature, 1-1 

main function, 1-2 

managing project files 

closing project, 6-2 

creating new project, 6-2 

loading project template, 6-2 

opening project, 2-1, 6-2 

saving project, 6-2 

managing workspace 

adding pane to tab, 6-4 

managing tab, 6-3 

menu bar, 5-1 
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merging log files, 11-10 

N 
navigation tree, 5-12 

Q 
quick start, 2-1 

R 
real-time test statistics, 9-11 

S 
status bar, 5-15 

system configuration 

setting alarms, 6-29 

setting events, 6-24 

setting log mask, 6-21 

setting others, 6-31 

setting test plan, 6-19 

system parameters 

displaying BTS information, 6-10 

editing and applying BTS information, 6-10 

exporting BTS information, 6-12 

importing BTS information, 6-9 

opening BTS configuration window, 6-8 

T 
toolbar, 5-6 

V 
view window 

amr window, 5-68 

anritsu scanner parameter chart, 5-56 

data service parameter chart, 5-63 

DTI scanner parameter chart, 5-58 

event list window, 5-69 

GSM/GPRS parameter chart, 5-45 

indoor measurement window, 5-77 

information window, 5-71, 9-12 

map window, 5-72 

message parameter chart, 5-50 

parameter window, 5-22 

UE state window, 5-70 

WCDMA parameter chart, 5-27 

window templates, 5-79 

W 
work space, 5-15 
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